Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Read in & Output to save CSV without file already open error?


I'm trying to update a CSV with a new row generated in my workflow.


I read in the old data from a CSV

I union my new row with the old data

I output the data


but the workflow gives an error "The process cannot access the file because it is being used by another process". I'm a little stumped at a way around this? 


For me, that happens when I have the file open in another application, such as Excel or Tableau. I'd start by making sure you don't have it open in another program.


Don't think so, it happens on my desktop and when I push it to the server. So I definitely don't have the file open in both places.


And when I put the input tool into a container and disable it the rest of the workflow runs fine


Adding a block until done fixes it

Alteryx Partner

This same issue pops up all over the place.  Block until done usually resolves it.

For example, if you download a file and then try to zip it you get this same error.


Glad you were able to figure this out @StephenMack! I had a need to open a .txt file, modify it, and save it back to the same location with the same name and was getting the same error. Adding in a Block Until Done fixed the issue for me!