Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Alteryx is here to help you solve your biggest data challenges. Read about the new Virtual Solution Center here.

R tool not writing out Data Frames

Highlighted
8 - Asteroid

I'm trying to write out two data frames from an R node. I know the code works because I ran the whole thing in R, and I obtain the desired output.

 

In summary, the code is looping through files, manipulating them, then I use rbind() to union the files at the end. 

 

The data frames are a mix of numeric and factor/character variables. I tried setting stringsAsFactors=FALSE, in order to deal with the possibility string variables turning into factors, but this did not work. 

 

I have attached the pertinent part of my workflow. Any insight would be appreciated. Thanks!

Highlighted
8 - Asteroid

I've discovered that part of my problem was because of how I was defining a date. 

 

In R, for example, it is possible to specify a date class as :

 

as.Date(variable, "%m/%d/%Y")

 

But alteryx does not like this form. I had to change it to: 

 

as.Date(variable, "%Y-%m-%d")

 

I am now obtaining output, but not the same output I get from running it directly in R. 

 

 

 

Labels