community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
New Data Science Blog

Check out the latest post: All Models Are Wrong

READ MORE

R error in loadNamespace error wtihout running any code

Highlighted

Hi all,

When I use R in Alteryx I receive an error that halts execution every time. I was able to run basic code before like readAlteryx, but now I can't run anything at all. Below is the error I get every time, no matter what code I run or even no code at all. I'm not loading any packages but I still get an error saying stringr won't load. 

I tried uninstalling and reinstalling Alteryx, I also tried detaching and installing the package from R terminal in the Alteryx bin folder. Has anyone else experienced this?

 

 

    R (1)    R version 3.3.2 (2016-10-31) - x86_64
    R (1)    rgeos version: 0.3-21, (SVN revision 540)
    R (1)    GEOS runtime version: 3.5.0-CAPI-1.9.0 r4084
    R (1)    Linking to sp version: 1.2-3
    R (1)    Polygon checking: TRUE
    R (1)    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
    R (1)    namespace 'stringi' 1.1.2 is being loaded, but >= 1.1.7 is required
    R (1)    Error: package or namespace load failed for 'stringr'
    R (1)    Execution halted
    R (1)    The R.exe exit code (1) indicated an error.

Magnetar

Hi @christinecao00,

Could you try also reinstalling the Predictive Tools version that matches your Designer version?  Sounds like some out-of-date packages in R, behind the scenes.

Hope that helps!

 - John

Alteryx
Alteryx
@christinecao00    If reinstalling the predictive tools didn't already solve your problem, you might try deleting the Alteryx R-library folders, and then reinstalling (rerunning the RInstall...exe).  Those folders include C:/Program Files/Alteryx/R-3.3.2/library      C:/ProgramData/Alteryx/R-library       C:/Users/user_name/AppData/Roaming/Alteryx/R-library.                (If you were running 2018.2 or later then instead of deleting C:/Program Files/Alteryx/R-3.3.2/library, you'd want to delete C:/Program Files/Alteryx/R-3.4.4/library.)

Hi,

 

The error is created by running the installation code (install.packages(c('[package]'), repos="http://cran.rstudio.com") twice; the first time it actually works, but the second time it seemingly cannot deal with the fact that packages are already installed and breaks the tool.

 

I could only find reinstalling everything as a solution online. After a few hours with the very helpful IT staff from MIP, I have found the following workaround: Go to C:\Program Files\Alteryx\R-3.4.4\bin and run the R environment from there and install the package --> (install.packages("[missing package]", lib="C:/Program Files/Alteryx/R-3.4.4/library")

 

Thanks to Edgar,

 

Regards,

Charles

Labels