community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Python: There is no valid metadata for the outgoing connection 1.

Meteoroid

Hi all,

 

I'm trying to implement stemming via Python in Alteryx. However, even when there is a "Success: writing outgoing connection data 1" message in Python, there are no data shown in the outgoing anchor. 

Stem_PythonError2.png

This is the error that I encountered. 

Stem_PythonError.png

I saw these posts.

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Error-in-Python-Write-No-Valid-Metadat...

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Python-Tool-Issues-with-Output/td-p/35...

However, by reverting my designer layout does not solve my issue. 

 

Please help. Have attached the workflow for reference. 

Stem_PythonError3.png

 

Thanks and regards,

W

Alteryx
Alteryx

Have you tried re-running the workflow? This error typically goes away after re running. After running the workflow, can you see output in the #1 anchor?

Meteoroid

Hi, I did rerun it. However, the issue persists. Tried closing and opening Alteryx as well.

Alteryx
Alteryx

Hi,

Can you confirm you tried the following:

Options > User Settings > Restore Defaults.

 

Can close designer and re-open and send me the following screenshots of your program:

1) Picture of Canvas before execution

2) Picture of Canvas after execution (without clicking on anything)

 

Thanks,

Andrew

 

 

Meteoroid

Hi @AndrewKramer,

 

Thanks for the respond. Have reverted the view to default. 

 

Before execution:

1_BeforeExecution.PNG

After execution:

2_AfterExecution.PNG

Result tab after execution:

3_AfterExecution_result_blank.PNG

These are the licenses activated in my local designer. Not too sure if it would affect the Python tools?

4_LicenseActivated.PNG

 

Thanks and regards,

W

Alteryx
Alteryx

Thanks for sending over this information. In this case, after execution of the workflow, the "No valid metadata" error went away, and is actually unrelated to the actual error of no data showing up in the output anchor (even though the Jupyter Notebook says data was written to anchor #1).

 

Typically, I have seen this error come from updating from older versions of Alteryx to a newer one that has the Jupyter functionality (2018.3 or 2018.4). Typically the fix is to reset the settings, which you tried in this case. 

 

I believe further investigation is necessary to determine the root cause. Can you email Alteryx Customer Support (Support@alteryx.com) and reference this thread?

 

Thanks,

Andrew

Alteryx Partner

Hi @AndrewKramer 

 

I am having the same problem as @wee and I tried the same suggestions.

 

After I had reset my user settings I opened the workflow again (The Tool Master | Python example)

 

This is how it looks when I open it2019-01-31 12_10_57-Alteryx Designer x64 - Python Workflow.yxmd.pngBefore

Then after I have run the workflow, the error goes away

 

2019-01-31 12_12_40-Alteryx Designer x64 - Python Workflow.yxmd_.pngAfter Run

But if I touch the Python tool, the error comes back

 

2019-01-31 12_13_01-Alteryx Designer x64 - Python Workflow.yxmd_.pngWhen I click on the Python tool

It seems rather cosmetically, but it gives some disturbance to get an error, especially if it is not there.

 

Best Regards
/Thomas

PS. At least I got do to all my setting once more ;)

Alteryx
Alteryx

Hi Thomas,

 

The specific "No Valid Metadata" error is more or less cosmetic. The Python Tool works off a cache of your data, allowing you to interactively build your workflow. It is more or less a reminder to re-run your workflow to push the changes made to the data in the Python tool (such as new columns, etc) to your downstream tools. As long as you can see output in the proper anchors when using the Alteryx.write() function you should be good.

 

Andrew

Meteoroid

Hi all,

 

After speaking to Alteryx support, I did the following to resolve this. 

 

1. Ensuring the my system setting in my designer are in place (Apparently, my errorlogs and engine logs are not created). You can reset or check you system setiing by going to Option --> Advance Option --> System Settings. 

2. Running on elevated (Administrator) seems to help with the problem as well. 

 

After these steps, I am able to see the Python in my output anchor. 

 

Thanks and regards,

Wee

Labels