Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Python Output not Working - There is no valid metadata for the outgoing connection 1.


I am trying to have an python tool output to 1 output. I am getting an error such a "there is no valid metadata for the outgoing connection 1. Run the workflow to generate the valid meta data.  I see this response after I run the workflow.  Any help would be awesome!  I have tried numerous things, found this simple script via the discussion forum from another user, but am not able to resolve it as they did.  


  Screenshot_2.pngPython ScriptScreenshot_1.pngWorkflow


I've attached the file to the post.

Alteryx Partner

I was only playing with this a few days ago .... are you sitting down when you are reading this ?



Simply delete those unused cells at the bottom so that it looks like this :


2019-02-15 20_30_01-Alteryx Designer x64 - Simple Python Output.yxmd_.png


Basically so that you're output is the last thing in the notebook, then it runs perfectly :) 


Typically this message is just telling you to re run the workflow. Do you see any output in the #1 anchor? As long as there is output, you are good to go.


No I don't see any output.  It doesn't show anything in #1 output.




So I am able to get that to show up, but when I click "1" green on the right-hand side it shows no output, does yours?Screenshot_4.png

Alteryx Partner

It works fine for me :) 


2019-02-17 11_31_20-Alteryx Designer x64 - Simple Python Output.yxmd_.png


Hi @jayordan 


I would recommend you reach out to Alteryx Customer Support ( They can walk you through the steps to get the output #1 anchor to show.





Anybody succeed with this issue?


I have try what it is in this post also what I found this other one, but I am getting this error once and once again.


I am using the python code used in this example, and even I go to Options>User Settings> Restore Default, I run the python code, then the full workflow, and even I see there is metadata on the output1, I am getting this error.


Anybody can help me please?





I am facing the same issue here. Have you found the solution for this? I would really appreciate if you could help me.




It was a known bug. What I had to do was to update to the new version and it worked for me. It took me getting to an alteryx python expert.

The information attached or contained within may include confidential and/or legally protected information of Deseret Mutual Benefit Administrators or the intended recipient. If you believe that you received this email in error, notify the sender immediately. Do not copy, distribute or disseminate the information and delete this email permanently from your system. The views or opinions presented herein do not necessarily represent Deseret Mutual Benefit Administrators.