community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Publishing from Alteryx to Tableau Server

Alteryx
Alteryx

Hey @dabears, sorry to hear you're having problems with the installation. The message given by the app doesn't give us a whole lot of information unfortunately, so let's try running the install as a workflow instead. To do this, follow these instructions (shown in the screenshot below as well):

  1. Find the collapsed Tool Container (51) that is contained within the bigger Install Tool Container on the right side of the workflow. Select it by clicking on the "prevent installation unless run as app" header.
  2. In the configuration panel, uncheck "disabled".
  3. Run the installation as a workflow by clicking the "Play" button in the toolbar.

You'll most likely still get the error you saw before, but with more information in the Results panel. There will probably be than can comfortably fit in a screenshot, so to capture all the relevant information, right-click anywhere in the results panel, and choose "Save as", save the file and attach it to a post here. (If you also don't mind sharing a screenshot for an easy visual reference for others who might come across this thread with the same problem before we get a fix in, that would be much appreciated too!)

 

installtableau.png

 

 

Atom

Thanks for the quick response!

 

I should note I have administrative access on my account, but tried our I.T. department to see if they would run it as administrator just in case... due to Alteryx not being "supported" :smileyindifferent: I was unable to see if security reasons were causing cmd.exe problems.

 

I've attached the error log, it appears to be an issue passing data to cmd.exe

 

I also have a ticket in as well, and will post any updates here.

Alteryx
Alteryx

One of the reasons we're trying out this installation method is because admin access shouldn't be required for it to complete. But if you'll bear with me in debugging it, we'll get to the bottom of this issue you're seeing.

 

Basically what we're going to do is manually run the commands that Alteryx was attempting to run and failing on. Ok, here we go:

 

1. Run the install as a workflow (you don't need to do this again if you still have it open from the previous run). The "prevent installation unless run as app" does not need to be enabled for this, but its fine if it is.

2. Find the Browse (51) tool in the Install tool container. This has the first set of commands that failed for you. They should like something like this:

installtableau.png

 

3. If the file paths don't look like real filepaths, take a screenshot and report back. Assuming they do look like the filepaths above, carry on to the next step.

4. Open up the command prompt by clicking on the Windows button on your Windows taskbar, and searching for "cmd".

installtableau.png

 

5. In Alteryx, copy the first line in the Browse (51) tool, starting with "md" (be sure to de-select the "Show whitespace" ¶ button if its selected before copying). Back in the command prompt, right click and select "paste" (don't use ctrl+v, it does weird things). Hit enter, and then repeat for the next two lines. If it gives you a warning message in any of the steps, just go ahead and do the next two so we can see all the messages. Here's what it looks like for me:

installtableau.png

 

Once you've done that, take a screenshot of the command line window and share it here!

Atom

When I go to look at the initial browse record, it actually crashes my Alteryx...  If I try and view the record it says outputted, it will freeze.

 

SS_Browse.PNG

 

I manually typed in the below CMD prompt commands, SS below:

 

SS_CMD.PNG

Atom

Despite having the files in their (assumed) proper places based on the script, this is the error I always get when loading Alteryx.

 

SS_MacroError.PNG

 

That line is the end of the script, so unable to troubleshoot further.

Alteryx
Alteryx

@dabears, are you on the new version of Alteryx (10.1) that was released on Monday?

 

It's interesting that those files were actually deleted when you entered the delete command in the command line. This indicates that the macro was at least partially installed for you -- and moreover, that the Run Command (26) tool shouldn't have failed, since you were able to manually run the same commands.

 

Let's do two things before we take this offline (the fact that the browse tool is crashing is something the product team will be interested in since that definitely shouldn't be happening).

1. Check the Browse (48) tool in the bottom left of the workflow. What does the output_dir field contain?

2. Run the workflow again as an app (or as a workflow with Tool Container (51) enabled, like we did previously). Does it error? Even if it does though, close out of Alteryx and reopen it, and then scroll to the right of the Tool Palette, looking for the "Tableau" category. If it's there, do you see the Publish to Tableau Server macro in the tool category? If so, then it would seem that the installation was successful, but for some reason the command line was returning an error, perhaps for a reason associated with why the Browse tool is causing Alteryx to crash for you.

Alteryx
Alteryx

Whoa, interesting. Are you unable to open Alteryx now because of that error? Deleting this file should fix that problem: C:\ProgramData\Alteryx\DataProducts\AddOnData\Macros\PublishToTableauServer.ini

 

I'm going to send you a private message to continue this, but for anyone following along, I'll post back once we have more information. If anyone else is running into this or anything similar, please do report it here -- it's very useful to know if this is an isolated random incident or if other people might be affected as well.

Highlighted
Alteryx Partner

Yes, I've only tried the latter. That is strange your calculated fields disappeared. My calculated fields remain when I publish the Alteryx generated .tde from Tableau Desktop to Tableau Server. I haven't yet tried using the macro to publish directly from Alteryx and see if my calculated fields remain. I hope so as I do have one workbook that requires this.

 

Sorry I couldn't be of more help!

Labels