Oh no! The Community appears to be haunted! Help us find all the spooky specters here.
We are currently experiencing an issue with Email verification at this time and working towards a solution. Should you encounter this issue, please click on the "Send Verification Button" a second time and the request should go through. If the issue still persists for you, please email support@alteryx.com for assistance.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Publish to Tableau Server Tool

sudhar46
7 - Meteor

Hi Team,

 

My client was asking me to find a way to publish the Alteryx result sets into Tableau server from where i could use the published data source which in turn Users could build the visualization on their own in the tableau server directly . I was able to achieve this solution using Event Run command Options


But it is not more convenient for my user as password is getting exposed as a parameter in "tabcmd" so am trying to make use of "Publish to Tableau Server tool" it dint work for me especially Saved Connections are not populating any information and also not accepting any inputs from my end as well.

 

Alteryx Version : Alteryx Designer Core 2019.2 ( Licensed Version )
Tableau Version : Tableau 2018.3

 

Steps Followed :

1) Downloaded the Publish to Tableau Server Install v2.0.0 – Alteryx version 2018.2 and Tableau Server 10.5 and newer from the Alteryx gallery. It did ask me for Admin privileges to install it but i ignored that message and went ahead for installation and nothing happens.

https://gallery.alteryx.com/#!app/Publish-to-Tableau-Server-Tool/599c93c8f499c7141c13a619/run

 

2) Used the Publish to Server tool from Connectors group and gave the user name and password and server URL and tried to connect but it was throwing me an error.

Attached error copy and also please suggest if am going in correct direction or recommend other ways to get this done. 

17 REPLIES 17
MeghanGohil
7 - Meteor

Hi Chris - I'm having a similar issue. We upgraded from 10.5 to 2019.2 for Tableau Server. I'm running Alteryx 2019.2.

Immediately upon upgrading, we get this error when logging in to Tableau Server using the Alteryx Publish to Tableau Server:

Status 404: Not Found.

I've verified that server URL is correct (https://abc.companyname.com) and that Site is filled in correctly. Username and password are correct as well.


ChrisHe
Alteryx Alumni (Retired)

Hello @MeghanGohil 

 

That does seem strange as a 404 error typically just means that your Tableau Server can't be seen at all regardless of authentication, etc.  Have you tried dragging out a fresh Publish to Tableau Server tool in a new workflow and trying to connect?  As a troubleshooting step I'd say to try not using your existing saved connection in the tool - just put in a username, password, Server URL and site name (I'd also encourage trying to put in no site name and connect to the default site to see those results).

 

If nothing seems to work or make a difference I encourage you to reach out to support@alteryx.com to resolve the issue and/or get any potential defects logged so they can be fixed.  Please report back to this thread so others can see what you've discovered!

 

-Chris

 

 

MeghanGohil
7 - Meteor

Thanks Chris. 

The problem is solved. The issue turned out to be that we had to enable Rest API, which is enabled through a command prompt that was run on the Tableau server.

rohit782192
8 - Asteroid
In 2019 version i amalso getting error as unable to find token.
MeghanGohil
7 - Meteor

Hi Rohit - you need to enable Rest API, which is enabled through a command prompt that was run on the Tableau server.

Here's a link:  https://help.tableau.com/current/api/rest_api/en-us/REST/rest_api_requ.htm

rohit782192
8 - Asteroid

Can you please help to share step please.

rohit782192
8 - Asteroid
AndrewW
11 - Bolide

An issue I find with the Publish to Tableau Server tool is the loss of Hyper file definition. It overwrites custom formats, data source level calculated fields, etc. The only workaround I have found for this to date is using tabcmd and Run Command in Alteryx. This article covers how to publish to Tableau Server from Alteryx and maintain the hyper file definition. Happy to hear alternatives that are simpler than Run Command.

Labels