community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Publish to Tableau Server Tool error

Atom

Hello everyone,

 

I was trying to output .tde file to Tableau server using Publish to Tableau Server Tool, but I have the error below when I tried to connect to Tableau server.

 

Alteryx version: 2019.1.4

Tableau Server version: 2018.3.3

 

This is the first time I'm using this tool so I don't have success history. I verified the username and password is correct and has no recent change. I also have tried method in another post like updating the https to http, but it doesn't work for me.

 

Could anyone help?

 

AlteryxToolError.PNG

 

 

 

Alteryx Certified Partner
Alteryx Certified Partner

Hi @XCCH 

Check out this topic. It seems the issue is related to SAML/SSO authentication.

Singin Error to Tableau server (using Publish to Tableau Server Install v2.0.0)

 

There are some Tableau Community threads that point to REST API documentation, which is more clear about it.

 

Cheers,

Atom

Thank you Thableaus for your reply.

 

I checked that post you attached but I didn't quit understand. According to some other posts here in the community, it seems many are able to use that tool. Do you mean this tool is not compatible with the my Tableau server version for now?

 

Atom

May I also ask is there any work around to automate the whole process? SQL Server---Alteryx---Tableau

Alteryx Certified Partner
Alteryx Certified Partner

@XCCH 

 

I'm not sure this has anything to do with your Publish to Tableau Server's version of the tool.

How's the authentication process in your company's Tableau Server? That's something you may need to double check. 

 

This tool functions as an API, and for what I see documentation on REST APIs from Tableau Server says that SAML/SSO authentication is not allowed. You can take a look in this help article:

https://onlinehelp.tableau.com/current/api/rest_api/en-us/REST/rest_api_concepts_auth.htm

 

Yes, it is possible to automate a SQL Server - Alteryx - Tableau data processing, you should search for some use cases in the community that might guide you better.

 

Cheers,

 

Atom

Thank you for your help, Thableaus.

Asteroid

you may also want to try the old publish to tableau server tool. I was using the most recent and i had the similar problem so i later found out that the version of the tool had a bug that the alteryx engineers are still working on. When i reverted to the version 1.09.2 and previous ones it worked just fine. Be mindful when i started using it i had no problem until it started giving me the same errors you are having with all my server credentials entered correctly. Give it a try.

Alteryx Certified Partner

It appears that there is a workaround by creating a Tableau account that doesn't rely on SAML. You basically create an account in Tableau server and then have an admin go in and manually change the password - this stops the account from going through the SSO/SAML process.

 

Here's a video that walks through the issue in regards to the Tableau command line tool (relevant info starts around 6:30)

 

https://www.youtube.com/watch?v=woNVLSPxWzI&feature=youtu.be%C2%A0

 

Thanks to @logiemeister  who linked to the video on this thread: https://community.alteryx.com/t5/Alteryx-Server-Ideas/Support-SAML-SSO-for-the-Publish-to-Tableau-Se...

 

 

Learn how to bypass SAML authentication when you need to authenticate to your Tableau Server using tabcmd or the REST API.
Labels