community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Publish to Tableau Server- Issues with Alteryx 11.3 (UNION tool)

Meteor

Hi all,

 

We use "Publish To Tableau Server" macro to publish Data Extracts to Tableau Server and when tried to connect to the Data Extracts from Tableau Desktop, we receive the following error. This has happened after the Alteryx Desktop & Server is upgraded to 11.3. After exploring the Alteryx workflow module by module, I came to a conclusion that this error is caused when the UNION tool checkbox "Set a Specific Output Order" is not checked. The error reproduces in case if the checkbox is not checked. May be an issue with Macro or UNION tool

TDE Eror.PNG

Please share if anyone have insights about this issue. 

 

Thank you!!!

 

Alteryx
Alteryx

Hi @mtakka1,

 

After checking the box to enable 'Set a Specific Output order' is the macro working correctly for you? 

Was this happening for all .tde files you were publishing?

 

Could you please describe which Union tool you are referring to in the Publish to Tableau Server (PTS) macro? If you have a tool number for the Union tool you found and the Macro that it is part of that would help greatly in investigating the issue.

 

 

Could you please include screen shots of the Configuration windows in Alteryx for the PTS macro?

 

Thanks!

Meteor

Hi PeterS,

 

Sorry if the question isn't clear enough. I was talking about the regular UNION tool in Alteryx. In the screen shot below, the UNION tool before the Publish to Tableau Server (PTS) macro is making the TDE corrupt if  "Set a Specific Output order" is not checked and works fine if it checked. I am not sure if the error is being caused by other things, but I was able to reproduce this error with the UNION tool.

.union.PNG

Thank you!!!!

Alteryx
Alteryx

Thanks for the clarification @mtakka1,

 

Are you able to attach example data coming out of the Left and Join outputs to this post so that I may take a look at what is going on with the data?  Does this only seem to occur with this data?

If you'd like I can reach out to you with an email address if you'd prefer not to share data on the discussion board.

Alteryx
Alteryx

Hi @mtakka1,

I wanted to reply with our findings for other Community users.  

 

The error was occurring when using the Publish to Tableau Server macro. When Opening the data on Tableau Server the error came up as :

 

An error occurred while communicating with Tableau Server.
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.

Tableau data engine error: 40460: SimpleDatabase::SelectMetadataName: expected found=1, actual found=0 (fk=18446744073709551615 name="Extract" nameTable="SCHEMAS")
The table "[Extract].[Extract]" does not exist.

We also tested writing the data to a local .tde file using the Output tool and got the same error noted in the link in point 2 below.

 

Ultimately the issue came down to a non-visible character in the data that wan't allowing the .tde file to be created correctly. A couple ways that this can be resolved.

  1. The non-visible characters could be removed using this method
  2. Or change the trouble column to a V_WString, as explained in this article.

 

Hope this helps.

Meteoroid

Hi @PeterS I am having this issue and I'm trying to work with provided solutions, but I think I am missing a step. I can't figure out what field ("trouble column") I should be removing non visible characters from? Or is it the field names? Should I use the regex solution for all of my fields?

Meteor

Hi @Brendan, you have to find that field the hard way. The way @PeterS worked out the problem is, he used the sample/filter tool to see if the issue is in first 50% of the data and then narrow it down by quarters. You can apply the same logic to find the issue and then use the regex to clear out

Labels