Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Publish to Tableau Server Error: Bad/ Illegal URL

Highlighted
Alteryx Certified Partner

Anyone have any insight into fixing this error from the Publish to Tableau Server Macro? 

 

Capture.PNG

 

I previously had the workflow running with the previous version of the macro, connected with the full page URL. However, I just upgraded to Alteryx 2018.2 and so upgraded the macro and now seem to be having issues. It appears like it is successfully creating the connection when I hit connect on the configuration pane but when I run the workflow I just keep getting this error no matter how much I tweak the URL formatting. 

 

I think the URL should be entered as "https://tableau.mycompany.com" but this does not appear to be working. Any insight into what I am missing here would be greatly appreciated!

Highlighted
Data Scientist
Data Scientist

Hi @Rachel_B,

 

Can you tell me which version of Tableau Server you are attempting to connect to? Also, which version of the Tool do you currently have installed? You can check this by right clicking on the Publish to Tableau Server Tool, selecting open Macro, and in the Workflow-Configuration window navigating to the Meta Info tab, and checking Tool Version. 

 

2018-08-09_10-32-14.png

 

Thanks,

 

Sydney

Highlighted
Alteryx Certified Partner

Hi @SydneyF

 

It is;

Tableau Server version 10.5

Alteryx 2018.2

and Publish to Tableau Server tool version v2.0.0

Highlighted
Data Scientist
Data Scientist

Hi @Rachel_B,

 

Just to confirm, did you restart Alteryx after downloading and installing the new Publish to Tableau Server Tool version? Does thee path that the Publish to Tableau Server Tool is saved in match the file path of the macro in your workflow? You can check the file path for each macro by right-clicking on the tool, selecting open Macro and checking the Path: set in the Workflow tab of the Workflow - Configuration window. We want to confirm that the new version of the macro has replaced the old version of the macro, and your workflow is not still referencing the older version.

 

Thanks,

 

Sydney

Highlighted
8 - Asteroid

Hi @SydneyF ,

 

I am receiving the same error message on a team member's computer. 

 

I have confirmed that they are using Alteryx version 2018.3.4.51585 and Tool Version 2.0 (the only tool version they have installed). I have attached screenshots of all errors and tool versions.

 

The odd thing is that it works on my machine, but not on theirs.

 

Any help would be greatly appreciated! 

 

Tool version.pngError Message.pngAlteryx Version.PNG

Highlighted
Data Scientist
Data Scientist

Hi @IJReed,

 

Can you please tell me a little bit about the differences between your machine, where the Publish to Tableau Server tool is working, and your teammate's machine? Are you running the same version of Alteryx Designer? The macro version is the same? What version of Tableau Server are you connecting to? Are the tools configured in the same way across the two machines?

 

Thanks,

 

Sydney

 

Highlighted
8 - Asteroid

Hey @SydneyF thanks for the quick response! I think I have narrowed the issue down to the permissions on Tableau Online. I will post the resolution if/when it works. 

 

Thanks again!

 

Ian

8 - Asteroid

Hi @SydneyF ,

 

After many attempts and the help of Gary Gruccio (Alteryx Ace), we were able to pinpoint the issue to having special characters in our Tableau Online password. Once we removed the special characters form the user's password, the tool worked like a charm.

 

Thanks!

Labels