ALTERYX INSPIRE | Join us this May for for a multi-day virtual analytics + data science experience like no other! Register Now

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Problem with new Alteryx Designer Admin version 2020.2.3.27789 writing out to One Drive

8 - Asteroid

I have installed the new version of Alteryx 2020.2.3.27789.  Now this morning I am getting errors writing out to Excel file on One Drive synced to my laptop consistently on a workflow I have run successfully every day since June 1.


Because our Alteryx server is on an older version, I also have 2019.4.8.220076 installed on my laptop in order to publish to the server.  Running the same workflow in the older version 2019.4.8, there are no errors writing out to the One Drive.


I have restarted Alteryx multiple times, and I have restarted my computer twice.


Errors are "unable to create backup of" and "unable to rename" when exporting to the Excel file located on the c:\ sync copy of the One Drive folder.


Are there issues with the new version?

17 - Castor
17 - Castor

Hi @harvjul 


This certainly sounds like a bug/oversight in the new version.  I would recommend sending an email to and adding the details of your issue



8 - Asteroid

I did send an email to support along with the screenshots, was posting in the Community in case others had seen issues.

I am using the Crew Macro parallel block until done to write out to multiple Excel tabs.  I wonder if it is the Crew macro incompatibility with the new version? I have reinstalled 2020.01 in order to use Alteryx today, but I may try 2020.2 without the Crew macro to see if the error persists.


Hi @harvjul,


Have you tested your workflow again with version 2020.3? This should no longer occur.

Florian Carrier
Solutions Engineer
8 - Asteroid

I think that this issue is now resolved with 2020.3.  Thanks!

5 - Atom

I still get the same error and I am on 2020.4.5.12471

It writes the file but fails at the end with the unable to create backup and Internal Error - Deadlock detected.


Any other ideas?