Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Predictive tools plugin engine error

8 - Asteroid

Hi, I'm trying to use the predictive tools for the first time and am getting the following errors:


Error: Linear Regression (3): Tool #4: The plugin "C:\Users\(My User Name)\AppData\Local\Alteryx\R-3.2.3\plugin\x64\\AlteryxRPluginEngine.dll" could not be loaded: The operation completed successfully.




Error: Linear Regression (3): Tool #170: The plugin "C:\Users\(My User Name)\AppData\Local\Alteryx\R-3.2.3\plugin\x64\\AlteryxRPluginEngine.dll" could not be loaded: The operation completed successfully.


I installed Predictive when I initially installed Alteryx.  Everything else is working fine.  Not sure what to do, I tried searching the error but couldn't find what to do next.  Thanks!

13 - Pulsar



Hard to say exactly what the root cause of it is, but typically what the issue is due to is the incorrect version of the predictive tools being installed. And by incorrect version, this could mean that you installed the tools intended (for example) for version 11.0, but you have Designer version 10.6. The other version related issue is if you installed the Admin version of the tools, but your Designer used the Non-admin installer.


Being that the error message are looking for tools in your user directory, my assumption is that you have the non-admin install.


If you're using Alteryx less than version 2018.1, you can find the predictive installers from here. If you are on 2018.1, then go to the new license portal to download the correct installer.


I do realize that you mention having installed the tools when you initially installed Alteryx, but possible that something occurred with that installation. Before reinstalling the predictive tools, I'd recommend going into your Add/Remove programs and uninstall any instances of "Alteryx Predictive Tools..."


Hope this helps!



8 - Asteroid



I know it's been a while, but I'm just getting back into this and I still can't seem to solve it!  I completely uninstalled alteryx and predictive tools.  I then installed the admin alteryx 11.5 and after that i installed the predictive tools (admin) 11.5.  Both installs went smooth with no issues.  


Yet I still get the exact same error!  This is very frustrating, and I'm lost on where to go from here.  I appreciate any help!!

8 - Asteroid

I figured it out!  Or a workaround at least.


A coworker of mine has predictive tools (11.5 admin) installed and working, so I had him copy his AlteryxRPluginEngine.dll file (from the C>Program Files>Alteryx>R-3.3.2>plugin>x64 folder) and send it to me.  I replaced my dll file with his copy and now it works!


Not sure that will help anyone else in the future, but glad to have it resolved nonetheless.


5 - Atom

I am having a similar problem in Alteryx Designer 2018.3. 


I have installed both the admin version of designer and the admin version of the predictive pack.


Is there an actual solution to this problem? The last user used a work around in his work-group, but since no one in my work group has this version of Alteryx, this isn't a feasible solution. 

13 - Pulsar



Being that there wasn't a definitive/ideal solution to this issue, I'd recommend contacting Alteryx Support to see they may have a solution or, more importantly, document the issue as a potential bug for further investigation.


I do know that depending on the security provisions your company's IT has on their PC's can make Alteryx behave unusually.

8 - Asteroid

Hi all, I am facing similar issue. I downloaded the predictive tools. I already have alteryx designer 2018.4. Now, I downloaded a sample workflow from the community and tried running. but getting the error.

Plz see screenshot.



13 - Pulsar



My guess is that you installed a mismatched version of the predictive tools to the version of Designer you have.


Open Designer and go to Help > About and confirm if you have the "Admin" or "Non-Admin" version of Designer 2018.4.x.



Afterwards, go to the licensing portal and navigate the options to show the downloads for the version of Designer you have (be sure to click "Previous Versions") and download the appropriate predictive tool installer.



If you've verified that the predictive tool installer and designer you have installed match, or still running into the same errors after reinstalling the correct version, you may need to get your company's IT involved. I have seen cases where certain programs and DLL's are blocked and require these to be whitelisted. 

8 - Asteroid

I followed the steps you mentioned. In the about section, it shows alteryx admin designer.

I downloaded the analysis pack for admin 2018 version.

While installing, I got error that I do not have sufficient rights to perform this action.

I need to contact company IT desk to fix this. Thanks.