community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Predictive Modeling: Linear Regression Error

Highlighted
Atom

Hi,

 

I am running a very basic linear regression operation (just Input and linear regression) and it shows the following error. I am not sure where to begin. I am using Non-Admin Designer version 2018.2.4.47804 on a Macbook Air running Windows 7 on Bootcamp. My system is 64 bit with 4 gb of RAM.

 

Here is a snapshot of the error:


Info: Linear Regression (2): Tool #130: 300 records were joined with 0 un-joined left records and 0 un-joined right records
Info: Linear Regression (2): Tool #4: R version 3.4.4 (2018-03-15) - x86_64
Info: Linear Regression (2): Tool #4: rgeos version: 0.3-26, (SVN revision 560)
Info: Linear Regression (2): Tool #4: GEOS runtime version: 3.6.1-CAPI-1.10.1 r0
Info: Linear Regression (2): Tool #4: Linking to sp version: 1.2-7
Info: Linear Regression (2): Tool #4: Polygon checking: TRUE
Info: Linear Regression (2): Tool #4: Attaching package: 'AlteryxPredictive'
Info: Linear Regression (2): Tool #4: The following object is masked from 'package:AlteryxRDataX':
Info: Linear Regression (2): Tool #4: XMSG
Info: Linear Regression (2): Tool #4: Loading required namespace: car
Info: Linear Regression (2): Tool #4: Attaching package: 'inline'
Info: Linear Regression (2): Tool #4: The following object is masked from 'package:Rcpp':
Info: Linear Regression (2): Tool #4: registerPlugin
Error: Linear Regression (2): Tool #4: Error in searchDir(dbDir, lang) :
Info: Linear Regression (2): Tool #4: Expecting a single string value: [type=NULL; extent=0].
Info: Linear Regression (2): Tool #4: Calls: <Anonymous> ... <Anonymous> -> XMSG_0 -> InitGlotKernel -> searchDir -> .External
Error: Linear Regression (2): Tool #4: Execution halted
Info: Linear Regression (2): Tool #107: Tool #34: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #107: Tool #36: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #107: Tool #37: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #107: Tool #38: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #107: Tool #42: 0 records were True and 0 were False
Error: Linear Regression (2): Tool #107: Tool #51: The field "Fit_Stats" is not contained in the record.
Info: Linear Regression (2): Tool #107: Tool #98: 0 records were joined with 0 un-joined left records and 0 un-joined right records
Info: Linear Regression (2): Tool #107: Tool #44: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #107: Tool #52: 0 records were joined with 0 un-joined left records and 0 un-joined right records
Info: Linear Regression (2): Tool #108: Tool #61: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #108: Tool #62: 0 records were True and 0 were False
Info: Linear Regression (2): Tool #108: Tool #67: 1 records were output
Error: Linear Regression (2): Tool #4: The R.exe exit code (1) indicated an error.
Info: Linear Regression (2): Tool #170: R version 3.4.4 (2018-03-15) - x86_64
Info: Linear Regression (2): Tool #170: rgeos version: 0.3-26, (SVN revision 560)
Info: Linear Regression (2): Tool #170: GEOS runtime version: 3.6.1-CAPI-1.10.1 r0
Info: Linear Regression (2): Tool #170: Linking to sp version: 1.2-7
Info: Linear Regression (2): Tool #170: Polygon checking: TRUE
Info: Linear Regression (2): Tool #170: Attaching package: 'AlteryxPredictive'
Info: Linear Regression (2): Tool #170: The following object is masked from 'package:AlteryxRDataX':
Info: Linear Regression (2): Tool #170: XMSG
Error: Linear Regression (2): Tool #170: Error in (read.Alteryx("#1")$Object)[[1]] : subscript out of bounds
Info: Linear Regression (2): Tool #170: Calls: unserializeObject -> identical -> substr
Error: Linear Regression (2): Tool #170: Execution halted
Warning: Linear Regression (2): Tool #171: There were no records present in the source
Error: Linear Regression (2): Tool #170: The R.exe exit code (1) indicated an error.
End: Designer x64: Finished running in 7.2 seconds with 7 errors and 2 warnings

Hi--

Did you end up figuring out the issue? I'm facing the same problem.

 

TIA

Meteor

Any updates on this?  We're seeing the same thing.

Labels