Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

PostgreSQL ODBC Driver

Alteryx Partner

Has anyone had any success configuring the ODBC driver to allow for faster read/ writes into Postgres? We are running 9.4 and using the standard ODBC driver from Postgres and read/ write times are so slow compared to similar functions connected to SQL Server. We have tried converting data types from text to varchar and other tweaks like that but are still finding it to be several times slower than expected.

Is there a commercial ODBC driver that is recommended or particular configuration to increase speeds? Thanks

Alteryx Partner

Hey nvalentin,


I have the same püroblem with postgres and odbc.

Do you have a solution to read/ write into postgres found?




Try to use a lowerODBC driver like 9.2.X


Commercial driver -







I'm noticing similar behavior in postgresql, and I'm using a 9.2 driver. Has anyone found a solution to this issue?

noticing all kinds of issues with these drivers on our Greenplum database. 


Failures, incomplete loads, etc. 


Have you tried applying this setting to your DataSource?


On "Page 1", make sure to make the following changes:

- Check "Use Declare/Fetch" box

I am using PostgreSQL ANSI(x64) driver via ODBC to connect to my AWS PostgreSQL database that has multiple schemas.

I am not able to specify the correct schema and table so my Workflow blows up because it can't find the table.

All it sees is the default schema "public". 

How do you configure the Alteryx Output tool to specify the schema?





I realized that to specify a specific schema and table you have to use "schema name.table name".

The problem I was having was two fold, my driver was not fully supported so I upgraded. The second part was I was not being able to change my field mapping from "map by name" to "custom mapping" and map all the fields appropriately.

I am good now.





Page 1? Can you clarify? 


This worked for me, thanks Linda!