Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Possible defect in output data tool.


Hi All,

I have a simple works flow that starts with a Run command tool which runs an exe file that connects to a web server and generates the results in a CSV file, then in the workflow I have formula tool that adds a new timestamp field in addition to the existing three fields in the CSV file, and the last tool in the workflow is an output data tool that appends the data (Delete Data and append) to a SQL Server table.

In configuration of Output data tool and in Append field map section you can use custom map option to manually map the fields. The issue is when you complete the custom mapping and save work flow the next time you open custom map, you don’t seem the mapping and in fact custom mapping option is grayed out, it seems you haven't lost the custom mapping but for some reason the option is grayed out, and you cannot edit it(make any chanages). Only when you run the workflow the custom mapping is back and visible.

I seems this is a defect in output data tool.


Alteryx version 9.5  


Alteryx Certified Partner
Alteryx Certified Partner

Hi H A,

I'm using V10.6 and 11 beta2 and cannot reproduce the behaviour you mention on my installation of Alteryx.

I don't know if this affects the behaviour, but can you check within the yxmd xml file, the <AppendMap> tag? Is <AppendMapping mode="Custom"> and then all the fields with the corresponding with Source and Dest correct?




Hi  ,


Yes in XML AppendMapping Mode="Custom"


and I have all 4 fields listed under that tag.


Field Dest  and Source are correct in XML


So yes it should work fine, but the issue with UI is still there. Well I think I should upgrade to the newr version of Alteryx 




I have the exact same problem now. I think it is not about version because I use 2018.4, but still the same issue. I know it has been a while but did you able to solve it? Thanks!