Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
It's the most wonderful time of the year - Santalytics 2020 is here! This year, Santa's workshop needs the help of the Alteryx Community to help get back on track, so head over to the Group Hub for all the info to get started!

Parse Error when using an IF function in the formula tool

Highlighted

Hi all,

 I am using an if statment in the Formula tool and getting an error that the data point is not recognized. I have a colleauge who uses the same workflow with no issue. Any thoughts on how I might resolve this on my end? Here is now the statment is written

 

IF [PLAN NAME] = "Health Savings Account" THEN "HSA"
ELSEIF [PLAN NAME] = "DependentCare Spending Account" THEN "DCSA"
ELSE "HCSA"
ENDIF

 

The error I get is that the plan name is unregonized, but it is a valid data point from the source.

 

 

Highlighted
Inactive User
Not applicable

Sometimes when you have cross tabs/transpose or other macro tools it will break a field cache causing Alteryx formula or filter tools to not recognize a field. If you run it through the error should go away. Have you tried running it and still obtaining the error?

Highlighted

Hi Ryan,

 Sadly yes. I have tried re-running a couple of times only to hit the same error consistently. I have event tried deleting the formula and adding it back, manually keying in the text, re-pasting what was origionally keyed in.... every time I hit the same issue.

Highlighted
Inactive User
Not applicable

Attach your workflow let's have a look

Highlighted
17 - Castor
17 - Castor

Hi @KatherineFuhrman 

 

I've seen cases before where the "space" in column names is not actually a space(ascii 32) but a non breaking space (ascii 160).  It's usually encoded this way in the input file.  In this case your IF statement doesn't match because [Plan32Name] != [Plan160Name] even though the 2 look the same.  [Plan Name] vs. [Plan Name].  (The second one here has ASCII 160 as the space, entered as ALT-0160.

 

The easiest way to fix this is to use a Select tool early in the workflow and change the name of the offending field to use a regular space.  

 

Edit:  Since your colleague doesn't have an issue, it could boil down to the choice of code pages/regional settings that you use.   

 

Dan

Labels