Do you use Alteryx in a language other than English? If so, we want to hear from you! Please help us improve the international experience of our products by participating in this 5 minute survey.

We are updating the requirements for Community registration. As of 7/21/21 all users will be required to register a phone number with their My Alteryx accounts. If you have already registered, you will be prompted on your next login to add your phone number.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Output to Excel error

MsBindy
8 - Asteroid

I have several workflows that are sending output to an Excel file.  When I open the Excel file I always get a message "We found a problem with some content..." Do you want us to recover as much as we can?...."     I always answer "Yes" and then I get a message about the repairs to the file which always says "Removed Records: Formula from /xl/calcChain.xml part"

 

I have no idea what any of that means.  I'm able to use the excel file, and run the macros in it.  However, I'd like to avoid those messages if I can before I hand these files off to someone else.

44 REPLIES 44
lwingebach
5 - Atom

I too was having the "Removed Records: Formula from /xl/calcChain.xml part" error message when opening up my Excel spreadsheet (.xlsx).  This was what was causing the issue for me, and how I resolved it: 

After having Alteryx output onto my .xlsx file by using the "Overwrite Sheet (Drop)" option, I was then going in to the .xlsx file and adding some columns manually in the spreadsheet (my output only had 6 columns, but I was then manually populating the 27-32 columns and then hiding them). 

 

Then, if I tried running Alteryx again, I believe the issue occurred because Alteryx didn't know how to drop the newly run output onto the sheet where I'd added the additional columns.  So, my workaround was to add the additional fields in Alteryx instead, so the number of output columns doesn't change when I make my manual updates in the Excel spreadsheet.

 

I haven't had the "Removed Records: Formula from /xl/calcChain.xml part" error message since I made this change.  Again, this is just what worked for me...  Good luck!

abell_dt
7 - Meteor

is there a way to output .xlsx files with live formulas from a .xlsx template using alteryx server?

MikeMKH
5 - Atom

I know I am very late to the party but I had a similar issue today with an Excel output that would give the "we found a problem with some content" error message.

The problem with the workflow I was working with was the FixedDecimal Type seems to be causing the issue when the Size is large, in my case I had FixedDecimal Sizes greater than 40.13 being passed to the Excel output.  I resized the offending Fields to be FixedDecimal Size of 40.13 and now the Excel output does not have any issues.

Hopefully this will help someone else.

bmurphy
5 - Atom

Typically this error comes from sheet names longer than 31 characters including spaces. So if you have take field name set for the sheet name or are using a formula to build the filepath and sheet name that's too long it'll give you the corrupt errors upon opening the file in excel.

jpoz
Alteryx
Alteryx

There is a known issue in the 2020.1 release:

Output to Excel using Skip Field Names doesn’t work when Preserve Formatting on Overwrite is also selected.
yaoerpi
7 - Meteor

This happens to me too when I try to output to a name range or specific cells - none of the solution above is working for me. It hurts when opening up files with the pop-up error, making it seem like corrupted. 

Amaya
5 - Atom

This fixed a similar error I was having too.. I shortened the sheet names up where the exported file truncated the tab name to.

 

Fixed it! Thank you!

Brennan
5 - Atom

For me the fix was going into the source sql and casting the field to float.  Then Alteryx interpreted the datatype as Double, then my excel issues all went away.   I would stay away from anything that results in Fixed Decimal, clearly there is some undocumented limitation to this datatype.

SciencePeak
8 - Asteroid

Hi @32bit 

I tried this. The error message does go away. But in my case, as I am writing data to column A to I with column J filled with formulas, the formulas in column J are still disappearing, which is the same case as before this zip change.

 

 

SciencePeak
8 - Asteroid

Hi @jpoz ,

 

I did not select Skip Field Names, but just Preserve Formatting on Overwrite as I am writing to a defined range like A1:I2000, with column J planted with formulas.  The issue is the formulas in column J will be all cleared after opening this xlsx file.

 

I have not yet found a solution on this. 

Labels