community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.
SOLVED

Output to Excel error

Meteor

Hi all,

 

No proposed solution matched my case (no formulas in excel, short worksheet names, creates new file everday, etc.). In fact, my report was running perfectly fine for several months and is distributed daily to dozens of folks.

 

My solution was - remove all images from Report Text tool. I'm not sure what the issue was but this seemed to fix the excel message. Report is less pretty but oh well :)

Asteroid

Thanks @32bit   I started this thread more than 2 years ago and see several different ideas,  but yours is the one that seems to have worked.

 

I don't have a zip-editor,  so googled your suggestion and was able to find nearly the same thing...with just the tiniest variation for those without the editor you mention:

  1. Change the Excel file's extension from .xlsm to .zip.  (Don't zip it...just change the extension)
  2. Unzip the contents and go to /xl/ folder.
  3. Delete caclChain.xml.
  4. Close the file  (I didn't rezip...just closed out)
  5. Change the extension from .zip back to .xlsm.  (Again, I did not unzip,  just changed the extension.)
  6. Open the xlsm file. ....and voila!  no errors
Asteroid

I'm glad you were able to get it to work @MsBindy, and without editing content_types xml file? If you use 7-zip (it's free) you can delete the calcchain.xml file without renaming it or extracting it first.

 

I did report this and others to Alteryx, but there seems to be zero interest in fixing it.

Atom

Wanted to mention here I discovered my cause for the xl/workbook.xml error. People have before mentioned that having too long of a sheet name can cause this - apparently having quotes or apostrophes in the sheet name is problematic as well. I wouldn't be surprised if there are other special characters that will cause this problem if they are included in the sheet name. 

Hi

 

I have the same problem, I have tried your solution but I do not have calcChain in my xml file or the caclChain.xml.

 

I am sure my problem is caused when one of my outputs to Excel has no records.

 

Any ideas?

Thanks

Helen

Asteroid

@HelenYoung  Corrupt file errors all look the same, but have different causes. Does your error specifically mention calcchain?

Hi

Thanks for the reply, no the error message did not mention calcchain, I got around it by appending instead of dropping the sheet.

Many thanks

Helen

Helen Young
Data Governance Manager
Strategy, Planning & Insight
 

Meteor
@32bit Thanks for the tip! This worked perfectly for my template.
Highlighted
Atom

I am getting the same error on a excel (.xlsx) workbook with no macros. In my workflow I had been trying out the output to specific cell method:

 

eg. write to file or database> users\username\desktop\document.xlsx|||$B2'>output options>overwrite file (remove)> skip field names. 

 

After the workflow is executed there are no errors, however the "repair" error pops up endlessly when trying to open the document even in spite of renaming the document and the output (a single field) is not output to the specified cell after the document repair option is selected.

 

Note though that there is no error if you do not specify a specific cell/cell range.

Hi everyone,

 

I got the same problem trying to output to specific cells. Opening the Excel file would sometime result in an error and delete all pivot tables and all the formating I had in the file, or there would be no records input at all. It happened around half of the time, I would reuse the same base report and the same data and it would work the second time, so completely random.

 

Then at some point I noticed in my data I had some figures with the format set as "Fixed decimal". I changed all the data with this format to the "Double" type with a select before the output to Excel, and it seems to do the trick. I launched the same reports ten or twenty times since then and I didn't get the same error I had previously.

 

You should try changing the type of your data and see if it works (or at the very least to limit the number of characters per field).

 

My two cents to all this is that Alteryx is working perfectly fine, but Excel probably fails to read/record some format correctly (maybe if there's too many figures after the coma?).

Labels