Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
ALTER.NEXT:

Join us on Dec 2 for a half-day virtual analytics + data science event!
US & CA customers only

SAVE YOUR SPOT
It's the most wonderful time of the year - Santalytics 2020 is here! This year, Santa's workshop needs the help of the Alteryx Community to help get back on track, so head over to the Group Hub for all the info to get started!

Output template with Pivot table getting corrupted

Highlighted
6 - Meteoroid

Hi All,

 

As per my use case I have to update source Data into a dedicated source data tab in a File having Pivot tab utilizing Source data tab. Once I paste the desired data-set into Source Tab and try to open the file, I am getting an error "We found some problem with the content "<file name">. DO you want us to try to recover........"

I have tried with newly created File (creating Pivot from the fresh). However getting same error. Any suggestion?

 

Additional Details:

When I open the corrupted File, a pop-up window appears with message:

Removed Records: Formula from /xl/calcChain.xml part (Calculation properties)

 

Listing Repair Details:

<?xml version="1.0" encoding="UTF-8" standalone="true"?>

-<recoveryLog xmlns="http://schemas.openxmlformats.org/spreadsheetml/2006/main">

<logFileName>error118240_01.xml</logFileName>

<summary>Errors were detected in file '<File Full Path>'</summary>


-<removedRecords summary="Following is a list of removed records:">

<removedRecord>Removed Records: Formula from /xl/calcChain.xml part (Calculation properties)</removedRecord>

</removedRecords>

</recoveryLog>

Highlighted
Alteryx Partner
Alteryx Partner

Your pivot table, is the source an actual excel table? If so, Alteryx is not writing the data to your "table" which is a named item/range in Excel (something like [Table1]). Alteryx is overwriting the data in the space on the tab you are telling it to. So, that means that part/all of that table is being overwritten and your pivot table no longer has something to refer to. I think this error may specifically be coming from the fact that part of this table still exists but it doesn't know what to do.

Treyson Marks
Senior Analytics Engineer
PK Global
Labels