community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

ORA-12592 TNS Bad Packet Error When Writing from .YXDB

Community Operations Manager
Community Operations Manager

@jbrider@TPR@jbyrne4@SeanAdams@MarqueeCrew Hi everyone.

 

Can you please confirm that the information @MarqueeCrew posted has been verified and set on your SQL servers? The error being thrown is coming from Oracle and as was stated  "This issue occurs when SQLNET.SEND_TIMEOUT is not set in the server side." "

 

To resolve this issue, add SQLNET.SEND_TIMEOUT=<seconds> to sqlnet.ora on the server side.

In addition, contact your DBA for exact value."

 

https://kb.informatica.com/solution/23/Pages/40/262530.aspx

 

 

 

Alteryx Certified Partner

I was running into a similar issue and followed the strategy that @TPR used to resolve the problem.  I removed the Formula tool before the data was streamed into the DB and used an Formula In-DB tool to create the field.  I can't explain why, but this worked for me.

Atom

I am facing the same bad packet error while trying to load the data from one database to another.  Even tried setting the timeout parameter in SQLNET.ora and loading from .csv.  Please let me know if there are any other options

Community Operations Manager
Community Operations Manager

@mythilip  Are you having this issue with all of your data being pushed to Oracle or just this particular dataset?

 

What version of Alteryx are you on.

 

Please make sure you are using a supported driver DataSources/Oracle.htm.

 

The error is being returned from the Oracle database. Based on further information I have found on this issue, it looks like that timeout setting that you mention needs to be addressed locally as well as on the Enterprise level if your database is not local. https://community.oracle.com/thread/4064411.

 

 

 

 

Atom

I get the error only for few tables and not all. As a workaround, now loading the data from .xlsx file to oracle table.  My alteryx version is 11.0.5

 

Community Operations Manager
Community Operations Manager

@mythilip a couple of things to check. If you are not able to resolve the issue, please reach out to our Support to assist at support@alteryx.com.

 

This error can be difficult to troubleshoot have you have seen. The issue may have to do with data types especially if you are able to read and write from other tables and are able to write to a .csv. So you may want to confirm your data types and adjust.

 

This also could be a network issue where for some reason writing to that table is taking some time and the call gets interrupted.

 

As you mentioned the issue can be the sqlnet, but if you have looked at this it may not be that.

 

In many cases with this issue the information above is typically the issue. If you are not finding this as the issue please submit a case with sample data and a detailed description. You can also reference this post.

 

Thanks

Alteryx Partner

To anyone else getting this error I have found a workaround using the 'Data-Stream In' In-Database Connector. 

Meteor

Hi Darren,

 

I am still getting the same error. Can you please describe your workaround.

 

 Best,

Jagdeesh Narayanan

Labels