community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Not enoguh byte to read after Batch copy sources from one share drive to input location

Highlighted
Meteor

Hi All,

 

Recently we encounter an issue (InboundNamedPipe::Readfile: Not enough bytes read, The pipe has been ended) during the inputting process.

Before we run the workflow, we will first use a batch copy script to copy the input source from sharefolder A to sharefolder B, then we will start the workflow by inputting the files in sharefolder B.

However, we receive the error message above.

Oppositely, if we run the input directly from sharefolder A or manually copy the files to sharefolder B for processing, this error doesn't come up.

It seems obvious that the batch copy script is the root cause. Nevertheless, I could not spot any difference/ issue with the batch copy script as below shown.

The script simply get today's date and copy those source files with the same date to another destination. My PC date format is DDMMYYYY.

Just want to see anyone encounter this issue and how you resolve it? 

 

@Echoon

 

set MM=%DATE:~3,2%
if "%MM:~0,1%" equ " " set MM=0%MM:~1,1%
set DD=%DATE:~0,2%
if "%DD:~0,1%" equ " " set DD=0%DD:~1,1%
set YYYYMMDD=%DATE:~6,4%%MM%%DD%

 

Copy /Y "M:\sharefolderA\*%YYYYMMDD%*.csv" "O:\sharefolderB\"


:endofscript


exit

Asteroid

Hello Eliot,

 

I had the same issue with a previous alteryx version. 

We called it pipe error in our team. The only solution, what is worked for us: run the workflow again. It was a few times when pipe error has came, but it worked after 4-5 run.

 

Wich Alteryx version do you use? Try to uprgade your version, if you are not using the latest.

 

I hope this will work for you too.

 

Cheers,

Kucsi

Meteor

Hi Kucsi,

 

The case is that if I input from the original sharefolder A, it goes fine.

 

However, if I input from sharefolder B which is copied by script from folder A to B, the workflow shows the below issue.

 

The workflow itself doesn't have any issue. It seems the script is the root cause. However, I could not spot any abnormal thing by using the copy script.

 

Thanks,

Eliot

Asteroid

Can you give me a test file and workflow for this? 

 

I'm curious about it, and want to try on our sharedfolders. 

 

 

Labels