Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Not all output files are being generated in the gallery

csh8428
9 - Comet

I have an analytic app in the gallery. It outputs 2 files a PDF done through the visual layout tool to the render tool and then an excel spreadsheet using the standard output tool.

 

When I run it from the gallery both output files are generated. When other users run it from the gallery they get ONLY the spreadsheet. Each user must enter their user credentials in order to run the workflow. I do happen to be an admin on the server, so not sure if that makes a difference.

 

Here's a screenshot showing the differences

screenshot.png

 

Here's a screenshot showing the output tool setup

File Setup.png

 

Thanks for any help!

 

-Craig

5 REPLIES 5
HomesickSurfer
12 - Quasar

Hi @csh8428 

 

Have you ensured that the pdf is selected in Manage Workflow Assets when posting to the gallery?

csh8428
9 - Comet

@HomesickSurfer Yep. It's checked in the assets: worfklow save.png

AZuc
Alteryx
Alteryx

@csh8428 , have you compared the logs between your execution and other's?

 

Perhaps the problem is before generating the file (0 rows, for example) or anything else.

 

You may consider add some Message tools in your workflow to add more details to the log.

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


csh8428
9 - Comet

@AZuc 0 Rows wouldn't be the issue. Both me and the other users are running the exact same workflow, yet we are getting different output files. Also, there is only one input data-source and the same data is going to both the PDF and the excel inputs. So, if 0 rows were the case then no files would be generated at all.

AZuc
Alteryx
Alteryx

@csh8428 , 

 

Still, is there anything different in the logs that can give us a hint about what's going on?

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


Labels