community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Not able to create directories

I am trying to create directories as below. Some of the folders under my path has spaces, and I am not able to create a directory. I am able to create a directory where the path don't have any spaces.

 

I am attaching my alterxy workflow. Please suggest

 

The bat file that is creating has multiple double quotes, tried few things but still not able to create directories

 

Command
"mkdir ""C:\Users\xyz\OneDrive - XYZ Technologies \Documents\reports Recon\Outputs\Apple"""
"mkdir ""C:\Users\xyz\OneDrive - XYZ Technologies \Documents\reports Recon\Outputs\Ball"""
"mkdir ""C:\Users\xyz\OneDrive - XYZ Technologies \Documents\reports Recon\Outputs\Cat"""
"mkdir ""C:\Users\xyz\OneDrive - XYZ Technologies \Documents\reports Recon\Outputs\Dolphin"""

Alteryx Certified Partner

Hey @praveen022 

 

You were almost there, you needed to add your capturing quotes, in the second formula rather than in the first

 

 

@LordNeilLord - Thanks for the solutions, and it worked like a champ. One more question I have is in the run command when I am giving the absolute path same as the output directory then the run command didn't work and it is throwing the error. But when I have run command under %temp% as you mentioned or under C:\Temp, it works.

 

Do you know what is causing the problem with the absolute path in the run command. (Write Source Output and Run External Program Command)

 

Thanks again

-Praveen

Highlighted
Alteryx Certified Partner

Hey @praveen022 

 

My guess is that c:\temp doesn't exist.....when you use %temp% that's the Alteryx Temp File Location that is deleted when the workflow finishes

Thank you. Directory location exist but still erroring out, but for now I am writing to %temp%

Labels