community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More
SOLVED

Neural Network Error Messages

Getting a Neural Network error message of the following:

 

"Error: Neural Network (6): Neural Network: Error in nnet.default(x, y, w, ...) : too many (11560) weights"

" Neural Network (6) Neural Network: The R.exe exit code (1) indicated an error."

 

NeuralNetwork.pngWorkflow

Meteor

This error message is telling you that the neural network you are running has too many weights (i.e. the combination of variable levels is too high).  You can change the number of weights in the model by going into the tool and increasing the maximum number of weights in the model.  This neural network will probably take a decent time to run.

 

However, you may want to look at how many distinct values there are in the variables you are providing to the neural net, in comparison to the number of records you are passing through the neural net.  For instance, if you have 20k records you are using, and the variable "Name" has 10k distinct values in it, "Name" will most likely just be adding noise to the model.  Unless you are using a large record set, setting max weights to the 12k you need seems a bit excessive to me, without any other knowledge.

 

Hope this helps.

Highlighted

Thank you for the help.  It's odd.  I changed the weights to 12,000 and it didn't work. I forgot to save it, reran the workflow with a  summary of distinct values of the five variables I'm using and it worked this time with the 1,000 weighs set previously.  It doesn't matter though as the results were less than stellar. 

 

You are definitely right in the fact that i have around 58,000 distinct variables out of 529,000ish records.  This is supply chain data and there are a lot of products with "0" inventory.  Regardless, this is good to know for further model building.  

 

Thanks again for the help.

 

 

Aurora
Aurora

Hey @JordanHowell,

 

I'm just going through treads to make sure that we've managed to solve the question - it looks like you and @chadanaber have found a solution that works.

If this problem is solved - would you mind marking this thread as closed by hitting the "Solution button" on this thread (the green one)?   If you still are struggling with this - feel free to reply with some sample data, and we can work with you to get to an answer that gets you back in business.

 

Cheers

Sean

Labels