Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!

SOLVED

Multi-Field Formula Issue

jmarleigh
7 - Meteor

Hi,

 

I have a strange issue that I'm hoping someone can help me out with.

 

I'm using a select into a multi-field formula, selecting two numeric columns, outputting with the new_ prefix and then using an iif expression, on the output of the multi-field formula I can see the two new columns are created, but once I drop another tool after the multi-field formula the new columns don't appear. I've tried both a browse and a select, with no results. I did the same thing with a regular formula tool and had no issues.

 

I'm just wondering if anyone can help me out.

 

Let me know if you require any further information.

 

Thanks,

Justin 

Claje
14 - Magnetar

I'm not able to replicate this locally 😞

Have you tried pressing f5 to refresh the metadata inside the workflow?

jmarleigh
7 - Meteor

Figured out the issue.

 

I was getting "invalid number" in my columns after using the select tool because I had duplicate headers in the file. Once I filtered out the duplicate headers and the NULL values. I then converted the data types using the select tool and lead that into the multi-field formula and it worked correctly.

Labels