community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

ModuleNotFoundError: No module named 'ayx'

Atom

Every time I run the python tool, the error I get says ayx module cannot be found. I am running version 2019.1.4.57073. I've tried uninstalling and reinstalling multiple times, but there is still no ayx folder in my Alteryx directory. Any advice on how to obtain this package or solve this issue?

# List all non-standard packages to be imported by your 
# script here (only missing packages will be installed)
from ayx import Package
from ayx import Alteryx
#Package.installPackages(['csv','nltk','nltk.corpus','nltk.stem','nltk.tokenize','unicodedata'])
---------------------------------------------------------------------------
ModuleNotFoundError Traceback (most recent call last) <ipython-input-8-3e8f6fb93cf1> in <module>() 1 # List all non-standard packages to be imported by your 2 # script here (only missing packages will be installed) ----> 3 from ayx import Package 4 from ayx import Alteryx 5 #Package.installPackages(['csv','nltk','nltk.corpus','nltk.stem','nltk.tokenize','unicodedata']) ModuleNotFoundError: No module named 'ayx'

 Thanks!

Alteryx Partner

Hi @astebbi ,

Try adding this to the location where alteryx is installed to check if you have this package or not.

\Alteryx\bin\Miniconda3\PythonTool_venv\Lib\site-packages\ayx

Thanks.

 

EDIT: Remove # in front of Package.installPackage in order to install packages else it will be passed as comment.

Atom
Hi @grazitti_sapna, I do not have the ayx package in this location. Is there a source I might be able to download/install it from? I doesn't seem to appear after a uninstall/reinstall of alteryx either.
Alteryx Partner

Hi @astebbi,

 

Could you please confirm which version of alteryx are you using and also if you are using admin or non admin version.

If you have a non admin version:

%LOCALAPPDATA%\Alteryx\bin\Miniconda3\PythonTool_venv\Lib\site-packages\ayx

 

Thanks.

 

Atom

I am running version 2019.1.4.57073. I am using admin version. My path of C:\Program Files\ Alteryx 2019\bin\Miniconda3\PythonTool_venv\Lib\site-packages does not contain an ayx folder. No directory in my Alteryx 2019 folder contains ayx either. 

Alteryx Partner

 I would suggest you to upgrade to the latest version if the problem still exist then talk to the support because the Python SDK tool comes with ayx package preinstalled, I don't know why there is no ayx folder in your case.

Labels