community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.
SOLVED

Model Comparison Macro Download Issue

Highlighted
Atom

HI All, 

 

I have tried to download the Model Comparison Macro from the Predictive District in the Alteryx Gallery without success.  When I try to import it, I get a message that the workflow was created by a more recent version of Alteryx and may contain tools not present in this version.  However, my version is the most current version (11.7).  When I try to workaround by going to the R folder in the Alteryx download and typing install.packages("ROCR"), I get a message that the Alteryx file is not writable, and it basically errors out.  Any suggestions would be appreciated. 

 

Thanks, 

 

Mboyce

Alteryx
Alteryx

The macro was created in version 2018.1 (the version numbering changed with 11.8=2018.1). What you can do is open the model comparison yxmc with notepad or some text editor and change the version number in the XML to 11.7. This should allow you to use it.

 

Capture.PNG

Regards,
Stephen Ruhl
Customer Support Engineer

Alteryx Certified Partner
Alteryx Certified Partner

You say you have the current version, 11.7, but actually the latest version is 2018.2, are you able to download that or are you restricted to the version you are on now?

 

Ben

Atom

I am having the same error.  I tried this but when I opened the XML the files already said 11.7 in that area.  Any other steps I can take to install this tool?

Meteor

Tip for Those still working on this. When I downloaded the model comparison tool there were two Alteryx Macro Files. Model Comparison and Confusion_Mat_Batch. If you are going in to change the version in the XML code this needs to be done to both Macro Files to prevent the error in the attached screenshot. 

Good Luck! 

Labels