Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Maps and spatial objects not showing in browse tool


Anyone else having issues with the browse tool not showing maps and/or the locally stored/generated spatial objects?

This issue has been happening for me for a while and I'm starting to need to deal with it a bit more actively.


The browse tool just stays on the "Please Wait... Rendering Map..." notice, and does this regardless of the selected base map.

It happens the same way for a small amount of single points and relatively simple poly-lines/polygons, so it doesn't seem like a data volume/complexity issue.

The browse maps works fine for on other computers for other people in my workplace and team, which I guess probably rules out corporate proxy/firewall issues.

I have tried reinstalling, but had no improvement.


Happy to try more ideas if anyone has some.

Alteryx Partner

This happened to me with the latest installation as well... Looks so low quality for such a powerful tool... :(




This is happening to me too.. it was working on a training workflow that now I try to run at work is not working. Wondering if it is a network / website / firewall issue if it is trying to download the latest map?

Alteryx Partner

I suspect there is a problem with the existing installation.

I shutdown the computer after an uninstall and re-install session.

After the restart, problem was fixed...


Could you send me a workflow that demonstrates the issue? 


Hi JPoz,


Workflow attached - I suspect mine will work as it was done through training through an Alteryx partner.


OP here (seems I forgot to update here when it was solved a while ago).

In my case, it was our corporate McAfee security suite blocking Alteryx's mapping sub-program (AlteryxBrowseMap.exe). After white-listing the Alteryx program directories (and sub-directories) in McAfee, everything was good again.