community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More
SOLVED

MapServerError - Requested font not found

Atom

I have a workflow that ran this morning that ran fine. Now when I run it I get an error.

 

The error reads: MapServerError - Routine:msFontsetLookupFonts()Message:Requested font (--Calibri) not found. Code:6

 

I have closed the application and opened and still receive the error.  

 

Moderator
Moderator

Hello @Rsalafia 


Could you please attach your workflow and some sample data?

This will help the Community to better troubleshoot the issue you are encountering.

 

Thanks,
TrevorS

Atom

TrevorS

 

Sorry for the delay in getting back to you. The workflow I was working with is very large with lots of confidential information. It's quite tedious (especially if there's a lot of inputs) but I ended up changing the font to avoid receiving the error. It did happen again with another workflow. The system doesn't like "calibri" sometimes, I guess. ;) 

Highlighted
Alteryx
Alteryx

@Rsalafia This error occurs occasionally when the workflow XML decides to mess with the font name. I've seen it before usually with Arial. You can uncheck the custom font check box and that should resolve the issue. You can also look at the workflow XML and find the issue font.  It will likely have two dashes (--) in front of it. Delete the dashes and you will be ok.

<Legend>
    <LegendStyle Position="Field" BackgroundColor="#f8f8f8" Font="--Calibri" Size="9" UseCommaSeparators="false" />
</Legend>
Regards,
Stephen Ruhl
Customer Support Engineer

Atom

Thank you so much for the response. I will be sure to try the next time I have the issue.

Labels