Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Manage Workflow Assets does not show assets and does not publish to server

Archaeopteryx
10 - Fireball

Upon publishing to the Alteryx Server, the dialog box with the link, "Manage Workflow Assets" does not show the assets, and, upon attempting to publish anyway results in a red-ink error "Error In Path". 

 

Any assistance would be appreciated. 

 

Chris

10 REPLIES 10
JagdeeshN
11 - Bolide

Hi @Archaeopteryx ,

 

Can you please either share a sample or give more information regarding which assets you have within the workflow.

 

Best,

Jagdeesh

Jean-Balteryx
15 - Aurora

Hi @Archaeopteryx ,

 

Have you checked your workflow dependencies for errors ?

Archaeopteryx
10 - Fireball

Hi,

See attachment.

The assets are Excel documents on a network drive. This network drive works successfully for us for years. I have looked at the file paths of all input and output documents and they are correct. 

 

Could interface tools cause such an error?

 

thank you,

Chris

 

HomesickSurfer
11 - Bolide

Hi @Archaeopteryx 

 

Designer will tolerate the use of more than 3 pipes when specifying a sheet.  The Server does not.

Endure that your reference to a sheet has only 3, eg: |||Sheet1

JagdeeshN
11 - Bolide

Hi @Archaeopteryx ,

 

Is it possible to share a sample path where you are getting this error.

 

It might be because the number of | (pipe) between the file name and sheet name in an excel output. It should be 3 pipes.

 

Best,

Jagdeesh

Jean-Balteryx
15 - Aurora

Can you share paths as it looks like there is a problem with some character ?

Archaeopteryx
10 - Fireball

Do all ".xlsx" documents have to have pipes and a sheet name? 

HomesickSurfer
11 - Bolide

Hi @Archaeopteryx 

 

Yes

Archaeopteryx
10 - Fireball

Thank you everyone for your help. I've discovered a couple of things:

This problem is not as easily detectable, but there are line breaks in the paths to the network drive. There were also some paths with "\\" double back slashes, which I'm not sure is a problem, but those got corrected anyway. The associate I'm working with is resolving these now. 

I'll report back what we find.

Chris

Labels