We have extended our Early Bird Tickets for Inspire 2023! Discounted pricing goes until February 24th. Save your spot!

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Make messages from SQL server visible in Alteryx

5 - Atom

It would be nice if you could see messages generated by SQL server in through the Alteryx tools that are communicating with the server.


2 examples to illustrate:
I was reading in a table, Alteryx gave me no errors, just a message that a certain number of records was read in (about 5M). Since I don't know the exact number of records in the table, just that there are approximately 5M, I thought everything was ok until somebody else pointed out that revenue past a certain date was missing. Turns out that reading in the data was interrupted by an error sql was throwing on a calculated field. Fixed the calculated field and was able to read in all records. It would have been nice if Alteryx had mentioned the error instead of reading in a partial table....

The other example was an output tool that was giving me this error: "An unknown error occured in II_PushRecord". This was caused by a fatal truncation error in SQL. The problem was solved by putting a select tool ahead of my output tool and forcing the field to match. I could have solved that a lot faster if Alteryx had giving me the error from SQL instead of the cryptic PushRecord one.


I understand that this might be challenging, not sure how the SQL drivers behave in regards to reporting error messages.
One workaround for the first error would be to count all rows in a table before reading it in, then reading it in and giving a message similar to the one you get from a Calgary tool (5,968 records out of 4,684,784 where read in). Maybe as an option because it might slow things down a bit?


Alteryx Alumni (Retired)



Alteryx should be able to show you messages generated by SQL Server, so this actually looks like a bug. 


We'll try to use the information you provided to replicate and fix, but will reach out to you if we can't replicate.


Thanks for letting us know!



5 - Atom

I am getting the same error ("An unknown error occured in II_PushRecord") and not sure how to debug. Has this issue been fixed?


I'm getting the message "An unknown error occured in II_PushRecord" from a Summarize tool that is reading in from a .yxdb and a .shp file.

Stephen Ruhl
Principal Customer Support Engineer

6 - Meteoroid

I'm receiving the same error.  I'm using an output tool to update 85k records onto a SQL database.  Originally I got a descriptive error, because the table didn't have its ID column tagged as a primary key.  I fixed the table and now I'm getting "An unknown error occured in II_PushRecord".  Any help on this?