Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Macro Output - Not Connecting (Macro works fine)

Highlighted
8 - Asteroid

Hi, I have an issue with with  macro, where I have attached an input file going in and a browse tool coming out and I run the workflow and everything is great. However, when I try to attach another tool such as a select or union, they can't seem to find the fields. I have a couple more macros on other workflows and they seem to work fine. I have spent a few hours trying to figure this out and can't pinpoint it. If I go into the macro and run the workflow then I do get one warning, but only for a column with a duplicate name, which I remove with the next tool anyway.

 

Anybody have any idea what could be causing this. Apologies, I can't share the workflow as it contains sensative data

 

 

The tool doesn't recognise the fieldsThe tool doesn't recognise the fieldsWorks fine - Display's fieldsWorks fine - Display's fieldsMacro workflowMacro workflow

Highlighted
8 - Asteroid

I think may have resolved this. It looks like the issue is with the data cleansing tool being the last thing in the macro workflow. I have added another select tool and it appears to work fine now.

 

Macro.PNG

Highlighted
5 - Atom

Thanks for this. I've just experienced the exact same issue with the Data Cleansing tool as the last element before the Macro Output in Alteryx Designer 2018.1.3.42973 - must be a bug...

Highlighted
Alteryx
Alteryx

@DamienMinter

@JY

 

Alteryx is aware of this issue.  You are exactly correct that you can add a Select tool just before your Macro Output.  That will restore transfer of the metadata and error-free operation.

Lisa LePome
Senior Customer Support Engineer -- Knowledge Management Coach
Alteryx, Inc.
Labels