Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?


Macro Error: The output connection was not valid




I have a new macro based on the community message titled: "CS Macro Dev: Conditional Processing with Detours"

I do not get how to resolve the error shown below. Note I have the tools built into my original workflow and am attempting to substitute the macro in place of them. Any help is greatly appreciated. 


Workflow Example: (Includes Detour tools the macro is to replace)




MACRO Configuration: DetourMacro.jpgDetourConfig.jpg






I could be wrong, but it looks to me like this macro isn't doing anything at all... You need a macro input to actually run your data through the detour tool.


Even then I'm not sure this is going to do what you want. Batch macros run the entire data stream through a certain number of times based on the control parameter. So, I think you will want that to be a single value. Again, I could be wrong.


Either way I think the error is being triggered because you have no data flowing through the macro.


Hope this helps,







I see your point regarding the macro. 






Interesting. So the reason this error is actually being triggered is because the detour tool does not continue processing on the inactive side. Meaning it doesn't even pass 0 records. It is almost as if the unused macro output didn't have a connection. I would recommend using a 'Detour End' tool to bring the two streams back together and using a single Macro Output.








I build a batched macro and then put that macro in my main workflow, and it worked the first few times and now I get an error saying "Record #1: Tool #5 Parse Error at Char(53): Unknown Variable "#1" ... output connection "Report_Date Macro" was not valid" .... how can the workflow work most times and not now? Anyone get this type of error before?


Thanks for any insight!

Sabeen Vora


Alteryx MACRO Workflow - Snapshot.PNGAlteryx Workflow - Snapshot.PNG



Hi @svora,


I got the exact same error when I sent nothing into the macro. Is it possible that the folder is empty?(no new data?)


If this does not solve your problem, I would recommend starting your own post as this one is quite old and will likely not get you as many useful responses.


Good luck,


  • I suggest putting a filter tool after the directory tool and filter where size > 0. This will tell you what files, if any made it through.
  • Second, limit the wildcard (*.*) on the Directory tool in case there are other files in the folder that could be hosing things up.
  • Looking at the macro, it is unclear what the purpose is. If you are simply trying to get the report date added to the data as a field, there are simpler ways without involving a macro.  
  • If the error persists, post your macro so it can be tested.

No, the folder is not empty. Thank you for the suggestion, I will create a new post.


Thanks for the Filter tip, I added it to my workflow after the directory.

As for the Macro on my workflow, that is where I am getting the error. The error message says, "Entry Point is invalid" ... What do we put in the Entry Point? Alteryx 'Entry Point' Error - Snapshot.PNG


Examine the attached macro.


It accepts a date field as input. Note that it does not use the Input tool but the Text Input tool to create a placeholder date that will be substituted. I also set the control parameter name to describe what to connect it to via the questions tab you will get when connecting it to your workflow.


Sometimes the errors are non-fatal in that they describe a data type error. That is the control parameter may be expecting a date vs. a string for example.


Hope this helps.