community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Announcement | We'll be doing maintenance between 9am-11am MT on Saturday, January 25th, which may impact your experience. Thanks for your patience as we work on improving the community!
SOLVED

Login Failed on Scheduler Running

Asteroid

Hi Everyone,

 

When I try and run this workflow through the scheduler, I recieve the following error:  "Error: Tool #11: Error opening connect string: Microsoft SQL Server Native Client 10.0: Login failed for user '5JDCPNET\ALTER-DT-00$'.\28000 = 18456' .  When I run this manually, it runs fine.  I think it has to do with the login string here.  When I run it manually, I assume it is using my login credentials.  When I run it through the scheduler, it uses the Login liste din the error above.  Is this the case?  What do I need to do to get this to run under me?

 

John

 

Alteryx
Alteryx

Hi there,

 

Is your scheduler configured to run on a server, or on your local machine?

Asteroid

It is running on a server.  I guess my bigger question is how do you configure the scheduler to run as a different user?  Currently it is running 5JDCPNET\ALTER-DT-00$ when I want it to run as 5JDCPNET\Altx_Procs

 

 

 
Alteryx
Alteryx

Try accessing your System Settings on the server and entering the desired credentials before scheduling your workflow:

 

 

SystemSettings_RunAs.jpg

 

Asteroid

Thanks JonA.  I read the community posting regarding System Settings and it makes perfect sense.  I did not consider this as an option becuase I do not have access to it nor did I know it existed.  I guess this is an option my Administrator will have to grant me.  Thanks again!

 

Asteroid

HI Again,

 

We are not running server.  I misinterpreted your question prior.  We have desktop with the scheduler add-on.  I am running Alteryx 10.0.0.58645. 

 

I cant find where to set the scheduler to run as someone else.

 

Can you use "RUN AS DIFFERENT USER" from the desktop?

 

John

 

Alteryx
Alteryx

Hi @JohnMaty - no problem and sorry for my delay.

 

You can find the settings to set the run as credentials from the image above using the System Settings icon that should be on your desktop (where you're locally scheduling workflows). This is what the icon looks like:

 

SystemSettingsicon.jpg

 

Once you double-click that, advance your menus to the window you see above in this thread.

  • Make sure your Environment set up type is Designer and Scheduler Only
  • In Persistence, DB Type - make sure you select SQLite
  • Finally, advance through with defaults to the 'Run As' menu, where you'll fill out chosen credentials

 

Run as different user from the desktop is only available in the full Alteryx Server version of releases 10.5 and later.

 

Asteroid

And in there was the problem.  When the Alteryx desktop application was installed on my machine, the administrative add-on was not installed.  I reinstalled and made sure to add this piece.  Voila!  Thank you for all the help!

 

Labels