Calling all Racers for the Alteryx Grand Prix! It's time to rev your engines and race to the stage at Inspire! Sign up here.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.
SOLVED

Loading files with * (asterix character) input tool

MartWClimber
9 - Comet

I've got an strange issue when loading data in with an asterix character (*) give me some headaches .

 

we recently upgraded to alteryx designer 2022.1 and some of the workflows are not performing as expected.

 

for example we got a workflow where we use an input tool and got something like:

server/location/part_of_filename_*.yxdb --> when creating this worklfow this was chosen because it loads all the yxdb file matching the file description.

 

now I see that part of the files are not getting loaded and alteryx is saying the following:

Warning: Input Data (1): The file "server/location/part_of_filename_xxxx.yxdb" has a different number of fields than the 1st file in the set and will be skipped

 

before the upgrade i've checked and saw that this worked because there was never an error like this (ran multiple times)

the files that are being collected are static and shouldn't change. (as far as I can see the files haven't changed)

 

did alteryx change in the way how to load files with an asterix character?

3 REPLIES 3
KrishnaChithrathil
11 - Bolide

@MartWClimber 

Are you sure all the files being loaded has the same schema?

KrishnaChithrathil
11 - Bolide

I believe this article would definitely help you.

 

Thanks,

Krishna

MartWClimber
9 - Comet

Solved my issue with creating a macro. 

https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/CS-Macro-Dev-Reading-in-Multiple-Fi...

 

i still find in strange that this is not a standard feature in Alteryx. within Qlik for example you can just concatenate tables all you want.

 

Labels