Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
ALTER.NEXT:

Join us on Dec 2 for a half-day virtual analytics + data science event!
US & CA customers only

SAVE YOUR SPOT
It's the most wonderful time of the year - Santalytics 2020 is here! This year, Santa's workshop needs the help of the Alteryx Community to help get back on track, so head over to the Group Hub for all the info to get started!

Linear regression "The R version 3.6.3 is not installed on this system"

Highlighted
5 - Atom

Hi everyone, 

 

I'm new to Alteryx and learning it as part of my course in school. So I installed a fresh Alteryx 2020.3 along with it's respective analytics package - both admin versions. 

 

I tried to create a work flow with linear regression, I have the predictive icon in my toolbar at the top and I can drag linear regression onto the screen or tree maps, any and all of them. 

 

Any time I try to run any of those tools I get the message that "The R version "3.6.3" is not installed on this system". 

 

The steps I've taken after thoroughly going through the support website and speaking with support by email:

 

- I have done a clean removal. Through control panel, program data files and tried to remove the reg keys but I can't find them on my system.

- reinstalled 2020.3 + predictive tools package

- used revo uninstaller to uninstall everything since i still couldn't see the registry keys

-installed the fresh new 2020.4+predictive tools

 

still seeing the same error message. 

 

At this point my thoughts are that it's a installation path issue. But when I look at the program files for Alteryx I see that R is installed there.

 

Any help would be super appreciated

 

Thanks in advance,

 

AH

Highlighted
Alteryx Certified Partner
Alteryx Certified Partner

Hi @alhabib 

 

With Alteryx it's possible to install it with a 'non-admin' installer and an 'admin installer', it's really important that both your designer version and your predictive version both make use of the same 'type' of installer (either both non-admin or both admin).

 

If you search windows for your Alteryx Designer version, if it has (User) suffixed at the end, this indicates it is using the non-admin installer, so therefor you should download the non-admin predictive tools.

 

If it doesn't then you need the admin tools.

 

Also make sure you are matching the version of designer with the version of the predictive tools (i.e. 20.3 tools with 20.3 Designer).

 

I hope this info is useful, I imagine (well hope for you), that it is simply a missmatch in these types.

 

Ben

Highlighted
5 - Atom

Thanks for your reply, 

 

 

I ensure they were the matching pair each time I've downloaded it. For good measure I even downloaded the non admin version of design and the predictive tools and in that instance as well it gave me the same error.

 

What would you suggest otherwise?

Highlighted
Alteryx Certified Partner
Alteryx Certified Partner

Okay, that's interesting, unfortunately I'm not sure I have any other responses up my sleeve. I've checked through the support tickets we handle at our company and I can't find anything that would help in this case.

I've found this forum post, which has a 3rd option, but I'm not sure if it's relevant with your problem: https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/Predictive-Tools-or-R-Tool-missing-...

 

In terms of moving forward, let's see if anyone else has any ideas, but you can also raise your issue with Alteryx support (support@alteryx.com).

 

Ben

Labels