Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.

Jupyter Notebook Won't Instantiate with Python Tool

Alteryx Partner



I have been using Python for a while now and was very excited to hear that Alteryx has now added the Python Tool to run Jupyter notebooks!

I notice that when I click on the tool, in the configuration window it says to click off of the tool and click back on to instantiate the notebook. However when I do this, nothing happens and it just displays the same message. I have a couple installations of Jupyter on my computer since I have been using it with different versions of Anaconda, but seeing as Alteryx installed its own python environment I don't see how this could be a problem.


I would be very helpful if someone could give me some insight on why the notebook won't instantiate when I click off and click back on, and it would also be really awesome if there was a way that I could link my Alteryx python environment to one of the ones I already have on my computer. 


Any help would be very much appreciated, 


Thank you!

Alteryx Partner

For some reason it is working now.. I guess problem solved!!

@Pianalyst What version of Alteryx are you running? I didn't have this problem with 2018.3.4, but now I'm having this exact problem with 2018.3.5. It comes and goes. Whenever I restart alteryx, it seems to work ok at first. Then I'll open several workflows, encounter python errors when I write bad code, and start and stop workflows. I'm not sure which of these normal activities is causing problems, but then it starts the behavior you describe where i click on the python tool and it doesn't want to load.

Alteryx Partner

@patrick_digan, I've noticed that when it gets stuck trying to load the Jupyter notebook, I can sometimes get it to work if I right click on the canvas while the tool is highlighted, then instead of choosing a drop-down option click off on the tool's configuration window. This has worked for me a couple times. Very odd behavior.. but once I get it to load it starts working. Let me know if this works for you!


Hi - I have been having this issue and have not been able to reach a solution. I did find the McAfee post and has our IT group take the recommended actions but I am still unable to use the python tool. Has anyone else experienced this? I am running 2018.3.4 on a Windows 10 virtual machine

Alteryx Certified Partner

I just had the interface crash on me twice. I was using the python tool for a few minutes and everything was working fine, then when I clicked onto the tool again at some point the interface wouldn't load. Even closing down and restarting the workflow doesn't work. The interface will load again only if I completely close Alteryx and restart it. But none of the code in the tool is saved. 
I'm on version 2018.4.5.55178


The exact same thing happens to me too.  Please let me know if you get a resolution for this problem!


I'm on version 2018.4.4.54346


Many thanks, nick