community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Join Tool Removing Data?

Alteryx Partner

Hi guys! I'm new here and I'm having a strange issue that I could not manage to fix and I wanted to know if anyone of you have ever had this problem. I have my dataset, which contains multiple rows for client_id, and a summarize dataset grouping by client_id to do some calculations like shipment costand etc. I used the Join Tool to join them and create a new column with repeated shipment cost values to each row of client_id and it worked perfectly for what I wanted to do. But here is the problem: when I uploaded my dataset to Powerbi and did a double check on it, my distinctcount of rows was not the same as my distinctcount of rows on the original database (from excel). It was something like 1355 x 1480. So I started to look for one of these missing 125 client_ids on my Alteryx flow, and it did not appear in the flow after the join with summarize part. So I went to check out individually on the two datasets that I used in the Jointool: my original one and the summarized one. For my surprise, the client_id was in both of them, but did not appear in the "J" of the Join Tool. I thought that maybe it had a blankspace or something like that, but in this case it would have appeared on the "L" or "R" from the Join Tool, which was not the case. My lines literally got removed and are not in any of the 3 outputs from the join tool. Anyone knows what to do in this scenario? Thank you in advance!

Alteryx Certified Partner

Dump the disappearing source records into a text input and share your workflow to see if the issue is repeatable across machines/environments. Is this an In-DB join or a standard join?

Alteryx
Alteryx

Do/did you have a series of tools after the join tool or a browse tool at least?

 

If you are using the Browse Anywhere functionality (the green icons) it may be that they didn't fit in the sample.

Highlighted
Aurora

Hi @pedrorm 

 

Place a filter after your input so that only the missing ID passes through.  Change your workflow setting to always show connection progress

 

config.png

 

Run the workflow and look at it from the input onward.  At some point the record count will go from some positive number down to 0.

 

Zero.png

 

This is the point where your ids are being removed.

 

Dan 

 

 

Alteryx Partner

Hi Joe. Yes, I have a browse tool and the number I'm looking for can be found there. The problem is right after the Join, he doesnt show up in any of the three outputs from the join tool (L, R or J) and that's why I cant find him on my final output that I've exported to PowerBI despite the fact that he is on my input dataset.

Alteryx Partner

Hi ryan. I'm having trouble to do that because, since the disappearing rows are not in the Join Output (L, R or J) they cant be separated.

Alteryx Partner

Hi dan! What filter would you recommend me to use? I'm having trouble to do that because there isnt any apparent difference between the field on my main data set and the summarize output. They are literally the same (with the same numbers of characters, without blank spaces, commas and etc) because they come from the same dataset (the main one)

Aurora

Hi @pedrorm 

 

Place a Filter tool immediately after your input tool and configure it like this  

filter.png

 

Change the field name to the id field from your data set and change "100062" to the id of one of the items that you're missing.

 

Dan

Labels