community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Issues with Publish .tde to Tableau Server Tool; FileName/Not Published but No Error

I'm getting this same error, my workflow is complete except publishing to the tableau server, which is hung up at 62%. Has there been any solutions or insight since this was last bought up?

Atom

I ran into the "duplicate table name" error and it took me a while to figure it out, felt silly in the end.  If using multiple instances of the Publish to Tableau Server macro in the same workflow, make sure they run in serial (block until done if not otherwise separated) and not parallel.  Two levels down in the sub macros there's a temporary yxdb file written before publish to Tableau that can have the same filepath and name.  I think there's file contention here.

I have the similar issue , My Alteryx wf gets struck at 62%, please post here if you find any solution.

 

Hello @MacRo

 

Can you please share the updated 'publish to tableau server tool'  . The current tool i am using is always get struck on 62% and takes forever to upload it into the tableau server.

 

Thanks

Rana

Atom

Hi @Macro 

 

Has there been a solution found for this yet? I also get stuck at ~62% progress when using the publish to tableau server tool. It appears that the 'Data Cleansing' tool might be an issue, as it always gets stuck at ~80% completion as well. 

 

Any thoughts here would be very appreciated! 

Meteor

Curious if anyone has found a solve for the Stuck at 62%? Just started getting that today for a workflow that otherwise ran successfully in the past.

Atom

My issue was in fact with the Data Cleansing tool - I removed it and used more manual processes to clean my data and it published to Tableau just fine. Not 100% sure what was going on under the hood. 

Alteryx
Alteryx

@BrennanH  @chanmar @KovvuriRanadheer @gnelson 

 

 

Regarding the stuck at 62% problem, have any of you resolved it? 

 

What version of Designer are you using?

What version of the Publish to Tableau Server tool are you using? 

What version of Tableau Server are you writing to?

Do you use a Data Cleansing tool and does removing it make any difference?  

 

 

Alteryx
Alteryx

@BrennanH @chanmar @KovvuriRanadheer @gnelson 

 

Does it make any difference if you uncheck the option to Save connection history?

 

Try unchecking Save connection history.png

Asteroid

I am also observing same issue where publish to tableau tool process doesn't make any progress beyond 63 %. After below message

 

Info: Publish to Tableau Server (20): The list of saved connections has been updated to include -- Server: https://tableau.xxxx / Site: xxx

 

Mostly this issue observed with high volume of data set (near about 33 M records). How we can troubleshoot this issue?

Labels