community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Issues with Publish .tde to Tableau Server Tool; FileName/Not Published but No Error

Asteroid

A couple of issues I've noticed from my first day playing with the Publish to Tableau Server tool. 

 

1. There were a couple of times(First couple of times I ran it) where my flow finished running without any errors, but the .tde was not actually published to the server. When I went into the log, I could see that there was a parentheses next to one of the entries upstream that said it was stopped by a tool downstream. 

 

I'm not sure what the issue was with this one. It hasn't errored out on me since the first couple of runs, but it is a bit alarming to me that it could not publish the .tde and also not cause an error flag when doing so. 

 

2. I have a dataset that I create/append to each week, in which I insert the file name("FileName" default) as a field in the data in order to create a trending view. When I left this field with the default header, I could see it going into the Publish to Tableau Tool, but it was not coming through my extract once I linked it up to Tableau to rebuild my dash.

 

For the second issue, I went in and changed the name to "File Name" from "FileName" and that made it show up in the .tde. 

Alteryx
Alteryx

Hi @FFFool, thanks for posting this. As far as the first issue, that's something we've not yet heard so far, and so we'll need more to go on to get to the bottom of it -- if you run into this again, can you take screenshots of your logs and configuration?

 

For the second one, this is indeed an oversight as the macro creates a field called "filename" that gets added to the input datastream. Sorry for the inconvenience this may have caused you, but we'll get a fix in and will report back when it's been updated on the Gallery. Thanks again for reporting this!

Asteroid

Hey MacRo, 

 

 

Attached is the log in Excel and snapshots of the Config(Blurred Name/Password but the same name/password work on other workflows) and Output saved in that file. There are a good amount of Warnings, but most of them should be there based on what I'm doing(Also exporting to an error file items that don't meet the join requirements). Notice that the Publish to Tableau tool seems to process before everything else, but never actually publishes to the server at the end. There are data conversion errors, but no regular errors that cause the workflow to stop or show up as red at the end.

 

 

Thank you,

Asteroid

So, I seem to have fixed my issue, but I'm not sure which of 2 things I did managed to fix it. 

 

The first thing I did was uncheck the box that says save connection history. 

 

The second thing was I selected the option to select project name, rather than enter project name. I had selected that before and selected the Refresh project name list... box. I unchecked that, and then went back to Enter project name.

 

Ran my workflow and it published no problem. I'm thinking it was probably the Refresh Project name list that did it, but I don't know. Either way it's odd that refreshing the list or saving the connection would override the actual publishing of the data source to Tableau. 

 

Now that you know the causes, hopefully you can put some of this information to good use. 

 

Thanks again,

Alteryx
Alteryx

Yep, the key is the "Refresh project name list" checkbox -- if that is checked, then it *only* updates the list of projects available in the dropdown above it. Nothing will be published to Tableau Server when that is checked.

 

(In the future we hope to make this a bit more streamlined, but for now you can either manually enter in the project name, or suffer the two-step process of refreshing the project name list and running then workflow, then unchecking it, selecting the project, and running again to publish.)

Alteryx
Alteryx

(I should also mention that having the "Save connection history" shouldn't have any impact on whether the datastream is published to Tableau Server -- but it sounds like the "Refresh project name list" option was the real culprit for you.)

Asteroid

I'm back with another issue with the Publish to Tableau Tool, that I've found. 

 

I'm publishing to two different Tab Server sites (Production and QC servers). Both are publishing to Default Project and both outputs have the same name. I'm getting an error that says a couple different tools are using a duplicate table name. 

 

On the scheduler, despite the final line not saying that there was any errors, I'm getting a red light on the results screen. Everything seems to be publishing properly. As far as I can tell, I don't see anything amiss on any of the outputs for the workflow. 

 

That said, we use that results page to guage if our flows were successful, so it's a bit annoying thinking it failed each time, just to check the log and see that nothing has actually failed within the flow. 

 

Any thoughts? I haven't tried changing the name of the data source published to Tableau, though, mainly because that would also require me to rework my Tab dashboard relying on the datasource. 

 

Thanks!

Alteryx
Alteryx

Hey @FFFool, can you post screenshots of these issues you're seeing, as well as more details about the configuration? For the first one, it sounds like you have two instances of the Publish to Tableau Server being called in the same workflow, is that right? For the scheduler issue, are you running that on-disk or in-db?

 

It will help to have more information, but here's some suggestions with the information I have now:

1. This sounds like a potential bug, but to get around it without having to rename the output of one, try putting a Block Until Done tool before the Publish to Tableau Server macros, so that they run separately. This should avoid the conflict if I'm understanding the issue correctly.

2. I'd recommend writing the Output of the Tableau macro to an output file. Then you can verify that the publish was complete. I can help you interpret this if youre able to post it here.

 

image.png

Meteor

I have been successfully using the new Tableau Server Refresh tool for a few weeks now. Seems to work pretty well once you get the initial configuration pieces out of the way. 

 

One issue I have, and I'm not sure if this is an issue or not, is that the Server Refresh tool seems to get hung up at 62% for a while. I'm currently pushing abot 9M records through to it, and it will take a couple minutes to get up to 62% once Alteryx starts getting to that part of the workflow, but then it hangs at 62% for the next 15 minutes. 

 

After about 15 min, I then start to see on the Results that the data is being updated and it provides the % uploaded in the messages. I guess I'm just not sure if this is normal, or if there is some problem between Alteryx and Tableau that is occuring here?

 

Any opinions would be helpful. Thanks!

Alteryx
Alteryx

Hi @drahn, how long does your workflow take to run without the Publish to Tableau Server tool? Is that a big time difference? I think the reason you're seeing the tool get hung up at 62% is that currently, it will try to logon and get authentication prior to the input data coming through it. This means that it very well may start showing its progress much earlier than when it actually starts uploading to Tableau Server. We are working on an update as we speak though that will fix this, so that the tool doesn't kick off prematurely. In you're interested in getting a beta version to test out, shoot me a PM with your email address.

Labels