Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Issues Outputting As A Tableau Extract


Everytime I run a workflow and want to output the data as a Tableau Extract it says it's finished running and exports a 30kb Tableau Extract that cannot be opened (it's much smaller than it should be). Does anyone know why this is and whether there's a workaround?

I've tried outputting my workflow as an Alteryx DB and then outputting straight from that to a Tableau and I get the same result.

Any help would be much appreciated.

I've narrowed the problem down to 53 records, all of which have foreign (non-English) characters in such as Ä Å Ö and Ø... could this be the reason why it doesn't like exporting the data as a Tableau?

I'm sure I've exported the same words before, with the same foreign characters, just in amongst my data, rather than at the bottom of my data.
Alteryx Certified Partner
Hi Andrew
I used Alteryx to read in SQL DB data containing these non-English characters and create a TDE & XLS :
- months ago on v8* (which was fine) and
- in December on (which was not correct).  The Dec outputs were created and opened fine but the fields with foreign characters have odd-looking characters instead of the character that should have been there (eg

I got the problem when I input from SQL Server DB but not when I input from an xls version of the data, so this might be a work around for you.

The Alteryx version still had issues going directly to a tde when using certain Unicode characters (the non-english letters).  I have not tested the more recent versions.  If you are on the most recent version and still have the problem then you may wish to raise it with client services and the product team

Hope that helps
Alteryx Certified Partner
Hi Andrew

Mike Akey from Client Services actually found a fix for this & let me know on 7 March:
If you change the field type to a V_WString, your non English character will output to tableau correctly directly from Alteryx. Not sure if this has always been the case or if it is a fix in the latest version, but there is a solution!

Thanks so much Mike!!!



I have similar issue of Tableau output. I'm on version 

The Tableau output not only have a 30kb file but also a larger .bak file. None of them can be open normally in Tableau.


I have changed all strings to V_WString and the issue is sill there.


Any idea?



using the latest version and a .csv file in input, I fixed my problem (output data in tde format - 30Kb), just modifying the Code Page setting in the Input Data options as follow :


Old value: default ISO 8859-1 Latin

New value: Unicode UTF-8 


Hope this helps





This is a hit and trial solution. Product team should take it seriously and publish a permanent fix. Alteryx logs say all the records have been written successfully, whereas we get a 30kb TDE.....its verrrryyyy frusssssttttaatttinggggg!!!!