community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Issue with running a workflow that calls a Batch Macro which has a Salesforce Input Tool

Highlighted
Meteoroid

Hi everyone,

 

I'm new to Alteryx. I need to create a process to obtain a date value from a table in my database and use the date value to pass in the filter inside a Salesforce Input tool. Hence, first I created a Batch Macro that contains a Control Parameter, an Action Tool that connects to the Salesforce Input tool (please see the attached "Figure1"). I then created a Workflow that contains a Data Input Tool to grab the actual date value in my database and connects the Data Input Tool to the Batch Macro (please see the attached "Figure2"). Whenever I tried to run the Workflow, I got the error message below:

 

Error: Batch_Macro_Eric (9): Record #1: Tool #1: Traceback (most recent call last):
File "main.py", line 73, in pi_init
RuntimeError: DecryptPassword only works with User and Machine encrypted passwords.

 

However, the Alteryx support created the same Batch Macro and Workflow on his machine and was able to run the Workflow successfully. We suspected there's some specific environment or security setting on my machine / Alteryx Designer. I have not been able to locate the setting. Can you please advise?

 

Thank you so much in advance!

 

Vu.

Alteryx
Alteryx

Hi @vutmo 

 

The error you see is triggered by the Salesforce input tool - when using this connector, your access credentials (username, password and token) will be encrypted on the machine where the workflow/macro was build and when you move it to a different computer, this will be unable to decrypt these.

 

Could this be the case here?

 

Michal

 

 

Meteoroid

Hi @MichalM 

 

I created the workflow/macro and ran it on the same machine which is my laptop. Do you have any suggestion?

 

Thank you much!

 

Vu.

Alteryx
Alteryx

@vutmo 

 

I'd try to delete the Salesforce Input tool and replace it with a fresh instance, pop in the credentials again and re-save the macro. Could you please let me know whether it makes any difference?

Meteoroid

Hi @MichalM 

 

Actually I'd tried that a few times but I got the same error. I'm running out of idea now.

 

Thanks for your help.

 

Labels