community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

IsString error

Asteroid

Hi All,

 

Im using text box for this i connected to error message tool with below condition 

ISEMPTY([#1]) or  ISSTRING([#1])

My business case was want to enter only number in the text box.

 

IsString Error.jpg

I got Error message. If I remove ISSTRING my code is running fine.

 

I got one more error like when I run the job in APP mode data is differs with the normal run. Why it's happening????

 

Could you help me how to resolve this.

Alteryx Certified Partner
Alteryx Certified Partner

 

Regex_match([#1],"[^0-9]")

 

That will return -1 or True if any character other than 0 through 9 is entered.

 

so Regex_match([#1],"[^0-9]")==0 should be what you are looking for.

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Asteroid

iserror Expression error.jpg

I used the expression which you gave still same issue. couple of days back as I mentioned above expresiions and it worked fine but when I reopen n try to running the code I got this issue.

Asteroid

I even wonder that when I run the code in analytical app it's not working properly where as when run in normal mode I'm getting perfect values(which matched my report). This is the first time I'm facing this issue could any one guide me how to solve this issue.

 

Regards,

sjn

ACE Emeritus
ACE Emeritus

Could you try

IsEmpty([#1]) OR !IsInteger([#1])

... or ...

IsEmpty([#1]) OR RegEx_match([#1],"^[0-9]*")==0

 

I think the earlier RegEx was basically correct, but was only looking for a single digit.

 

The attached workflow elucidates this.

@SJBI can you post a sample workflow or trimmed down version (.yxwz or .yxzp) that demonstrates the error? It would be hard for me to debug without your actual workflow. If I have a sample of your workflow that is exhibiting problems, I can debug it and then post back to let you know the steps I took. 

Labels