Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Alteryx is here to help you solve your biggest data challenges. Read about the new Virtual Solution Center here.

Invalid Range Error When Creating New Sheet

6 - Meteoroid

Hi everyone,


I am running into the error pictured below. I deleted the sheet name in my output file. I am now trying to create a new sheet with the title "Provision." I have checked everything and including the "Overwrite Sheet (Drop)" option although that won't work since the sheet does not exist in the output file yet. Please advise. I have attached my screen shots below.




Thank you,





8 - Asteroid



Seeing the entire workflow or even a screenshot would probably help in pin-pointing the issue, but a first question would be are there more than one path in this workflow pushing data to the same workbook in Excel?  Excel locks the file when the first instance is opened then will block anything else from being written to it at the same time.


If this is the case, insert Block Until Done Tool(s) to allow the process to compete separately for each push to Excel thereby unlocking it for the next one.


Hope that makes sense and that is the actual issue.  Not sure what else it could be without knowing more about it. 




6 - Meteoroid

Hi Daniel,


Thanks for the response. I have separate workflows creating and overwriting data (drop) tabs into the same output file under different sheet names so it would be tricky to use the Block Until Done tool. I had to create a whole new output data file to export to in Excel which fixed the issue. It was working just fine before when I was overwriting data (drop) until it started rejecting the word "Provision" but would still create a new sheet with "Provision 1" and the like. I am not sure if this is a glitch in Alteryx but it was odd.




8 - Asteroid

OK.  Are you running them from a scheduled process or running manually?  If it is on schedule/server, perhaps you just need to space the schedules a little further apart to avoid overlapping use of the same Excel workbook.


I tried a few tests in Excel by creating a sheet AND a named range called "Provision" and it will update the Named Range over the worksheet.


I then removed the named range and ran it again, and it knew to populate the "Provision" worksheet.


Have you tried just removing the output tool and trying to connect anew?  I wonder if the tool is just holding onto something "broken" and adding a new output tool would reset it.


Hopefully something in this post is of use to you.  I am grasping at straws at this point, since I cant mimic the issue.