community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More

Integrating Here Data for Geocoding

ACE Emeritus
ACE Emeritus

Has anyone tried or been successful integrating Here data for geocoding?

 

Thanks!

Highlighted

Fairly straight forward to use the HERE Geocoding REST API: https://developer.here.com/signup/geocoding?cid=sem-adwords-iprospect&campaign=Tier2-Brand-All-BMM&a...

 

Sample attached looking up four addresses using the geocoding api. You will need to get an AppId and AppCode and set in the workflow constants.

 

If dealing with a large set, you would probably want to look at the bacth process. This would be a lot fiddler - think you would need to do some form of iterative macro pausing on each iteration before seeing if the batch completed.

ACE Emeritus
ACE Emeritus

Thank you sir.  I will be testing the options later today.

I'd take a look at google maps API as well.

Tried it for another community question: https://community.alteryx.com/t5/Advanced-Analytics/Find-Nearest-Metro-Station/m-p/26509#M995
Alteryx Partner

Hi @andy_moncla

 

we offer a geocoder based on HERE Location Platform.

 

Have a look to:

https://www.youtube.com/watch?v=o0qSgLlsUE0

and/ or

https://www.youtube.com/watch?v=tOaLps2_DuI

 

On the video installing casaGeoSpatial you can see all our apps we developped  on HERE Location Platform.

 

Mathias

 

 

You will learn to geocode an address list in Alteryx Designer with HERE Maps. It works for all countries. Further information: http://www.casageo.de/en/casageospatial.html
Asteroid

I could not get it worked for some reason it gives me an error under create points icon

 

app_id and app_code shoudl be inserted as below right, or am I missing something?

 

"https://geocoder.cit.api.here.com/6.2/geocode.json?searchtext=" + UrlEncode([Address]) +
"&app_id=" + [12345] +
"&app_code=" + [12345] +
"&gen=8"

Asteroid

is there a trial version so that we can test it out

You put the AppId and AppCode as workflow constants:

workflow constant.jpg

 

It should then be picked up by the formula tool. I tested on mine and does work still.

Hello,
I have generated my APIs and configured them according to what you have shown, but it is giving permission error (HTTP / 1.1 403 Forbidden? Access-Control-Allow-Origin: *? Content-Type: application / xml; charset = utf-8? Date: Tue, 24 Oct 2017 13:29:52 GMT • Server: nginx-clojure • X-NLP-IRT: 785 • X-NLP-LOG: • X-NLP-TID: 98db64b2-064f-457e-b191-ef4d244e11fd • X-Served-By: i-0c). Do you know what it can be?

Now it worked. I closed and opened the Alteryx and started working.
It looks great!

Labels