Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Announcement | We'll be doing maintenance between 9am-11am MT on Saturday, January 25th, which may impact your experience. Thanks for your patience as we work on improving the community!

Input File used in the Alteryx App on Gallery




It looks like there were errors while validating the workflow.


It says it cannot access the shared drive, and the input file is not found.


So for UNC, I literally clicked on "All UNC" button at the bottom left in Workflow Dependencies pop up and clicked "Ok". 









Alteryx Partner

Appreciate your help in solving this.


I have access to one share drive and I kept my input files on that. When I run the workflow from my local machine it takes the input from the share drive and give the results as expected, however when I publish the workflow on the Alteryx Gallery (I made sure my files are/aren't being packaged whenever I save a file to the gallery), it resulted in "File not found" error.


On the whole, my question is my Alteryx Workflow when published on the Alteryx Gallery should always take the input from Share Drive or Share Point so that my workflow works without installing Alteryx on another machine and takes the most recent file(s) from the Share Drive or Share Point.


Hi @gajender,


The issue you face is similar to mine that I was able to work through.


Essentially, any file you are using on a workflow that is published on a gallery must reside in a folder that you and the alteryx server have access to. For this you may want to reach out to your IT folks. 


Once you have your file located there, then you will have to use UNC for the path when saving the file. 


If you read carefully through this thread, the details you need should be there.


Let me know if you have any other questions.







I have an error i was wondering if you could help!

I Have an App, that takes an input file (chosen by the user) and runs the workflow and sends an email. Whenever i run it locally as an App, i don't have a problem, but whenever i try to run it on the gallery or another user tries to run it, we have the below error.

I tried to check and uncheck the 'validate assets' Inputs and ouputs but nothing  


Any help would be appreciated !


The job InsuranceV2 did not complete successfully and resulted in the following errors:

  • File not found "C:\ProgramData\Alteryx\Service\Staging\1756_40f8707a89984e7f3b1j11f364db\In_5da732e2306dc00chf0\Insurance 10-16-19.xlsx|`Sheet1$`" (Tool Id: 14)

@sguindi It looks like there is an issue with the gallery where the file that the user is uploading isn't working as expected. Can you share the workflow/pictures of how the file browse is connected to the input tool? Here is how my file browse is connected to an input tool with the action tool setup like so:

Annotation 2019-10-16 112856.jpg



So I prompt the user to choose a file, and it goes through the Formula tool, to capture the Filename and Full path to be used later in the WF.. and then i pass the Full Path to the dynamic input so it can read the file 

@sguindi Nothing obviously wrong is jumping off the page at me. Any chance you can send over a sample workflow that fails in your gallery and I can test on my side?