community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

InboundNamedPipe: ReadFile error reading from simple Snowflake Query

Asteroid

I have seen a lot of folks with this kind of error - and many times they are using a lot of joins or unions, and that is what is causing it.

 

Mine is a simple query, a select tool, and a browse. The query runs in Snowflake in 728ms generating 9,408 rows of data.

So, not a lot of data - and the query is under 10 lines, just selecting fields and the only where stmt is looking at the last two weeks of data.

 

I get the error on this query when trying to run it with the regular Input Tool. As a test, I tried running it using INDB Tools, and it runs just fine in about 6 seconds.

As a further test, I ran using INDB query, then used a Data Stream Out tool - and got the error again.

 

I closed all my apps, re-booted, ended a few processes after startup, re-opened Alteryx with nothing else running and tried again... same result...

 

I run a lot of workflows that generate millions of rows of data, so I find it odd that a small query that generates a really small amount of data would come up with an error that seems to be computer memory related.

 

Has anyone encountered this and actually solved it? I can likely export my data from Snowflake to excel, then import that into my workflow, but am hoping I can actually find a fix for this instead of a workaround.

Alteryx Certified Partner
Hi @michael_heitz It looks like it's been awhile. Did you ever figure this issue out?
Labels