community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

In-Database join not returning any columns, works without In-Database?

Fireball

I'm trying to do an inner join on 2 queries using the In-Database tools. If I immediately use the data-stream-out tool on each query and use the join tool everything works great. When I try to use the in-database join tool I get a really long error about no columns returned. This is my first attempt at in-database tools and I figure I must be missing something basic.

 

Anyone see what I'm doing wrong? Thank you!

 

no columns returned.PNG

 

Fireball

Even more strange to me is that my In-Database browse tool gives me the same error after the preceding tool doesn't error? If I use data-stream-out I can see that there is indeed information in there...

 

no columns returned.PNG

Asteroid

Hi,

 

Did you figure this out?  I am getting the same error in a similar situation.  

 

Thanks!

 

Highlighted
Fireball

I went back and forth with support for a long time. It turns out that I have a MySQL database hosted on AWS and Alteryx doesn't support that yet (even though they say they support MySQL).

 

Basically Alteryx was generating SQL statements not compatible with MySQL because something was tricking it.

 

I haven't been able to use in-database because of the issue. Sorry I couldn't be more help!

Labels