community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

I am trying to download data from Liveperson Data Access API, can anyone help.

Meteoroid

Has anyone in this forum been able to use Alteryx to download data from Liveperson Data Access API. All my attemot have been in vain.

 

https://<domain>/data_access_le/account/{accountID}/le/agentActivity?startTime=<startTime>&endTime=<endTime>

 

The domain being lo.da.liveperson.net

Alteryx Certified Partner

Hey @oselle

 

What errors are you getting when trying to access that endpoint?

 

What authentication method are you trying to use?

 

Meteoroid

Here are the typical errors messages I have been getting;

 


<?xml version="1.0" encoding="UTF-8" standalone="yes"?><error><time>2018-09-10T03:58:42.564-04:00</time><message>bad request</message><internalCode>5</internalCode></error>

 

I am using API Key for authentication.

 

Despite getting a connection established method,no data is downloaded

Alteryx Certified Partner

According to their documentation, the problem is an issue with the header or body parameters.

 

Annoyingly they don't give an example of a complete call to see, for example the StartTime should be in milliseconds...that doesn't make sense.

 

I would try experimenting with your start/end date parameters and see if that works

Meteoroid

My start and endtime  are all in milliseconds

 

startTime=1536015600000&endTime=1536102000000

 

Let me know what you find out. 

 

Thanks

Alteryx Certified Partner

That makes sense, 

 

Is there another, simpler call that you can try to make sure you are passing the OAuth corretly?

Meteoroid

@LordNeilLord

 

I have tried this;

 

http://<domain>/api/account/{accountId}/service/{serviceName}/baseURI.json?version=1.0

 

Replacing a domain with lo.msghist.liveperson.net , accoundId with myID and the msghist. This also gives the same error.

 

Not quite sure what to do next.

 

Alteryx Certified Partner

Usually you have to pass the API key as part of the headers,

 

Have you read through these pages?

 

https://developers.liveperson.com/authentication-introduction.html

Meteoroid

@LordNeilLord

 

I am no longer getting errors with no data being retrieved. 

Meteoroid

@LordNeilLord

 

Just wondering if you have been able to figure / find out  anything else to resolve this issue. 

Labels