community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.9

The latest release includes several enhancements designed to improve your Community experience!

Learn More

How to stop workflows & apps opening with an old version of Alteryx?

Highlighted
Atom

I have upgraded to version 10.5, however, when I click on a saved workflow or app, it attempts to open it using the previous version, and I see the screen for 10.0. I am forced to open the file by opening Alteryx first, then Ctrl+O the file I want. I have already worked on the files using the new version, so I receive an error message when my computer attempts to open it with 10.0.

 

I have removed all references to 10.0 in the Program Files folder, and tried to navigate to the latest version by using Open With... But it still tries to open using 10.0.

 

Any ideas?

Meteor

Have you tried to associate the *.yxmd files to the new version of Alteryx?

 

Right click on the file -> open with -> Browse

 

Then browse for the folder of the Alteryx version that you want to use.

 

Or you can visit Control Panel\All Control Panel Items\Default Programs\Set Associations lookup for Alteryx files and associate to your latest or required Alteryx version.

 

Hope this will help you!

I agree with @SergioD's methods to fix the issue. It sounds like some registry entries weren't updated. For what it's worth, the registry entries could reside in one of two spots:

 

1) If you've never had a non-admin version installed, then HKLM will be the only entries:  [HKEY_LOCAL_MACHINE\Software\Classes\Alteryx xxxx\Shell\yyyy\Command

2) If you've ever had a non-admin version installed, then HKCU will trump the HKLM: [HKEY_CURRENT_USER\Software\Classes\Alteryx xxxx\Shell\yyyy\Command.

 

I like having a non-admin version next to my admin and this causes problems whenever the non-admin is installed. It will switch all my registry entries to the C:\Users\... directory and then my admin install no longer is the default for opening files. I just update the registry whenever it's pointing to C:\Users\... instead of C:\Program Files. Going through the open with method or control panel method is much safer, but I just wanted to provide the actual registry entries for anyone  interested.

 

Capture.PNG

Alteryx Alumni (Retired)

Registry keys can be exported as files by right clicking on the key. Once its a file, you just have to click on it to change the registry settings.

pamW
Asteroid

The Registry changes were the only way for me to change the configuration from the old version towards the new one.

Meteor

I tried the Control Panel change first, but I wasn't able to fix the problem.  The problem was fixed with the registry edit method, though.  Basically what you need to do, I found, is go to both registry locations, find the AlteryxGUI.exe file in there.  Open each of those .exe files in the two locations.  Determine which one launches the latest (correct) version, and simply copy the correct one over to the other (incorrect) location.  That's what I had to do, at least.  Don't know if it'll be the exact same for others.  Good luck, people!!  :-D

Asteroid

This is working for me thank you!

 

Any idea what the difference between edit and open is in the Shell folder? Trying to figure out if I need to change both in every folder.

 

This seems like a task for a registry editor script since I am counting 18 places to change the path. If I can find the time i'll try to figure out how to do so.

Labels